It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Crucible / BitBucket issue: fatal: ssh variant 'simple' does not support setting port

 

image.png

 

Crucible Version:

VersionFishEye 4.5.3 20180321104931 
Crucible 4.5.3 20180321104931

BitBucket Version:

Atlassian Bitbucket v5.11.1

SSH Version:

# ssh -V
OpenSSH_6.6.1p1, OpenSSL 1.0.1e-fips 11 Feb 2013


Git Version: 

# git --version
git version 2.17.1

 

My crucible install can access the list of repositories in my BitBucket install, but it errors on importing the files, making it so that we cannot open code reviews for anything in our BitBucket.

 

Is there an easy solution to this issue?

 

Thanks

 

3 answers

1 accepted

0 votes
Answer accepted

I found more error information:

Error testing connection.
Error talking to repository: 

fatal: ssh variant 'simple' does not support setting port

at com.atlassian.fisheye.git.GitScmConfig.testConnection(GitScmConfig.java:120)
at com.cenqua.fisheye.RepositoryConfig.testConnection(RepositoryConfig.java:390)
at com.atlassian.fisheye.spi.admin.impl.DefaultRepositoryAdminService.testConnectionFor(DefaultRepositoryAdminService.java:964)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

Connection failed.
Dick Wiggers Atlassian Team Aug 07, 2018

Hi Mike,

Thanks for providing these details. I had another look, and it looks like you're running into this bug: FE-7016 (Fisheye stops repository indexing with Git 2.16.0 and higher).

This is caused by a bug in Git 2.16.0+ (https://bugs.chromium.org/p/git/issues/detail?id=7).

As suggested in the FE-7016 bug, please try one of the workarounds:

 

  • downgrade Git to version older than 2.16.0 or
  • upgrade OpenSSL to version 6.8 or newer

I hope this resolves your issue.

Cheers!

Thank you!  Updating OpenSSH solved my problem!

Dick Wiggers Atlassian Team Aug 08, 2018

No worries, Mike! Happy to help.

 should mention that I have already re-created the application links. 

0 votes
Dick Wiggers Atlassian Team Aug 06, 2018

Hi Mike,

I did a quick Google search on this error message, and I found:

The internal behavior of Git (>=2.16.0) for SSH tool detection changed and TortoiseGitPlink is not detected any more as ssh or plink compatible.

This only affects if the SSH URL contains a port. For now, you need to set the environment variable GIT_SSH_VARIANT to ssh, in the next version of TortoiseGit 2.5.7 this will be done automatically.

See https://tortoisegit.org/issue/3139

This comment sums it up:

run in git bash git config --global ssh.variant ssh

 

Source: https://stackoverflow.com/questions/48417505/fatal-ssh-variant-simple-does-not-support-setting-port

I hope this helps!

I tried this and it still didn't work.

Dick Wiggers Atlassian Team Aug 06, 2018

Hi Mike,

I think it's best to raise a ticket with our Support team at support.atlassian.com. Please be sure to link them to this Community thread.

I hope your issue gets resolved soon.

Cheers!

Unfortunately, we're a small team and only need the 5 licences provided by the starter licence, and therefore do not have access to the support system.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published Mar 14, 2019 in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

929 views 1 16
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you