It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Could /opt/atlassian/pipelines/agent/data/id_rsa become invalid during Pipeline execution ?

Hello,

I have a deployement script which use to work yesterday whic basically stops services, deletes queues, delete former version, copy the new one and restarts the services, all this using a private key.

This morning it seems to succeed the first 3 steps but when it comes with the copying and all subsequent steps, i have the following error:

no such identity: /opt/atlassian/pipelines/agent/data/id_rsa: No such file or directoryPermission denied, please try again.Permission denied, please try again.Permission denied (publickey,password).lost connection

However, it is the exacte same key which is used in the previous steps. Could the key be corrupted or deleted ?

Regards,
Chris

9 answers

We have the same issue, our scripts worked on friday, now suddenly they are not working anymore with the exact same output as yours.

I have opened a support ticket with Atlassian, this feels like something they have changed which is affecting us.

We've been having the same issue today, I've been working on a new deployment process for our services which worked on friday. This morning we got the exact same error message.

Same issue here, everything worked fine on friday.

Yep, same for us. Our ansible deployments are failing to connect to the server with error:

no such identity: /opt/atlassian/pipelines/agent/data/id_rsa: No such file or directory

 

Everything worked well yesterday.

Same here

Same here ! I use pipeline with AWS Code deploy and now I've got the same error. 

0 votes
Ronald C Atlassian Team Aug 28, 2017

You can try adding the following steps in your bitbucket-pipelines.yml which configure to load the SSH-key to ssh-agent as a workaround to proceed with your build:

          - eval `ssh-agent`
          - ssh-add /opt/atlassian/pipelines/agent/data/id_rsa

You can check out the bug report created by @Robin Rijkeboerfor more updates from our team - https://bitbucket.org/site/master/issues/14729

Solved! Thanks!

0 votes
gsackett Atlassian Team Aug 28, 2017

Hi Everyone,

We've deployed a fix for this issue and will be continuing to investigate the root issue that caused it.

Would you be able to provide us the url of the specific repo that you were having issues with?

Please feel free to let us know if you encounter any further issues, or have any questions.

Cheers,

Bitbucket Pipelines Team

It works for me now, the issue was in repo : https://bitbucket.org/invirtus/rtls.invirtus.io

 

Thank you

Hi Gary,

 

We are not using Pipeline in our repo's but I still have the issue with the SSH. I'm currently working back on HTTPS which works fine. I had the issue with all my repo's, the team repo's and private repo's.

 

Cheers Sander

gsackett Atlassian Team Aug 29, 2017

Hi Sander,

This issue/post is very specific to Pipelines.  For your issue, I would suggest creating a new question in the community, or creating a support ticket at getsupport.atlassian.com, and our support team will help you troubleshoot the issue.

Cheers,
Gary

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

Atlassian supported Jenkins integration for Bitbucket Server

We’ve been building a plugin to integrate Bitbucket Server and Jenkins CI, and I’m excited to announce that our alpha is ready to download and install. It lets you seamlessly configure a Jenkins job ...

940 views 1 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you