Could /opt/atlassian/pipelines/agent/data/id_rsa become invalid during Pipeline execution ?

Hello,

I have a deployement script which use to work yesterday whic basically stops services, deletes queues, delete former version, copy the new one and restarts the services, all this using a private key.

This morning it seems to succeed the first 3 steps but when it comes with the copying and all subsequent steps, i have the following error:

no such identity: /opt/atlassian/pipelines/agent/data/id_rsa: No such file or directoryPermission denied, please try again.Permission denied, please try again.Permission denied (publickey,password).lost connection

However, it is the exacte same key which is used in the previous steps. Could the key be corrupted or deleted ?

Regards,
Chris

9 answers

0 vote

We have the same issue, our scripts worked on friday, now suddenly they are not working anymore with the exact same output as yours.

I have opened a support ticket with Atlassian, this feels like something they have changed which is affecting us.

0 vote

We've been having the same issue today, I've been working on a new deployment process for our services which worked on friday. This morning we got the exact same error message.

Same issue here, everything worked fine on friday.

Yep, same for us. Our ansible deployments are failing to connect to the server with error:

no such identity: /opt/atlassian/pipelines/agent/data/id_rsa: No such file or directory

 

Everything worked well yesterday.

Same here ! I use pipeline with AWS Code deploy and now I've got the same error. 

0 vote
Ronald Chia Atlassian Team Aug 28, 2017

You can try adding the following steps in your bitbucket-pipelines.yml which configure to load the SSH-key to ssh-agent as a workaround to proceed with your build:

          - eval `ssh-agent`
          - ssh-add /opt/atlassian/pipelines/agent/data/id_rsa

You can check out the bug report created by @Robin Rijkeboerfor more updates from our team - https://bitbucket.org/site/master/issues/14729

0 vote
Gary Sackett Atlassian Team Aug 28, 2017

Hi Everyone,

We've deployed a fix for this issue and will be continuing to investigate the root issue that caused it.

Would you be able to provide us the url of the specific repo that you were having issues with?

Please feel free to let us know if you encounter any further issues, or have any questions.

Cheers,

Bitbucket Pipelines Team

It works for me now, the issue was in repo : https://bitbucket.org/invirtus/rtls.invirtus.io

 

Thank you

Hi Gary,

 

We are not using Pipeline in our repo's but I still have the issue with the SSH. I'm currently working back on HTTPS which works fine. I had the issue with all my repo's, the team repo's and private repo's.

 

Cheers Sander

Gary Sackett Atlassian Team Aug 29, 2017

Hi Sander,

This issue/post is very specific to Pipelines.  For your issue, I would suggest creating a new question in the community, or creating a support ticket at getsupport.atlassian.com, and our support team will help you troubleshoot the issue.

Cheers,
Gary

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

709 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot