Configuring Bitbucket 5.4 server.properties

To whom it may concern,

I have some problems configuring Bitbucket 5.

I had following setup with Bitbucket 4.14 and Jira 7.3.4. which worked:

Apache toward the internet with https. A single FQDN with context paths, /jira for JIRA Software and /bitbucket for Bitbucket. There are reverse proxies configured for JIRA and Bitbucket. Application links are made between JIRA and Bitbucket. OAuth(Impersination). 

I upgraded to JIRA 7.5.0 and Bitbucket to 5.4. I tried to find a document explaining more thorough how to configure Bitbucket's server.properties.

There were some general, superficial explanations. Now I tried to get some more thorough explanations but all I get is:
Screenshot - 09282017 - 08_31_39 AM.png

 

When I go to Bitbucket settings and look at the application link the both way communication shows me that the OAuth(Imper) is working normally, but when I go to Jira settings I see a OAuth invalid signature.

 

Now please send me a thorough parameter explanation of the server.properties configuration so we can fix this and continue to work normally, since we are trying to fix this for the past day.

 

Regards,

ETC

1 answer

0 votes

Hi Daniel,

Hopefully you're able to access our resources again.  There is a good document on the properties for Bitbucket titled Bitbucket Server config properties.

The first thing I would do is remove the Application Link and re-create it per the Application Links Troubleshooting Guide.  Breaking the link does not lose any data so you won't have to worry about that.

  • When you take a look at the JIRA logs what errors do you see in relation to the Application links?

We have a knowledge base article titled OAuth error oauth_problem=signature_invalid that may be of use.  Just in case you're unable to view the Confluence page here is the important information from that article:

The Application URL of the link does not match the URL that the remote application is reporting. This can be caused by:

  • The Base URL on the remote application is set to something other than the Application URL defined on the link
  • A reverse proxy or port forwarding is configured, and the "Host" header is reporting the wrong host name or port
  • If you are using NGINX as the reverse proxy and using the proxy_cache directive 

Here is the Resolution:

 

Base URL

  • Ensure the Base URL is correct for each application.

Application URL

  • The Application URL should match the Base URL of the other application, unless you're bypassing a reverse proxy.

  • If the Application URL does not match the Base URL (and you're not bypassing a reverse proxy) then delete and recreate the Application Link.

Reverse Proxy

  • If using a reverse proxy or port forwarding, ensure the application is correctly configured for use with a reverse proxy.

NGINX Reverse Proxy with  proxy_cache directive

  • Do not use the proxy_cache directive in the nginx configuration

Hopefully that helps provide clues on where to look and any changes you need to make.

Note: In times where I was unable to access Confluence, I used the cached link to access the page until it came back up:

Screen Shot 2017-09-28 at 10.54.52 AM.png

Alternatively I have also used the Wayback Machine to find articles that are archived.

Cheers,

Branden

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

434 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you