Committing to two copies of the same repo where only one sees changes of the other? Edited

I'm in an odd situation where we're getting commits from the repo on someone else's host, but we were told that there was no reason for our commits to merge in with their copy of the repo... which to me opens up the possibility of avoidable refactors, desynchronization, and merge conflicts, mostly on our side, and possibly repetitively.

Can someone explain what the benefits or most likely detriments are? I technically do have access to make a pull request to their repo but I don't understand the reticence or refusal to allow us to give our commits to them.

2 answers

1 accepted

Seems like the answer is that both parties should see each other's source code.

0 votes

 

Hi Dave, sending pull requests to someone else's repo is a very common practice so I can not really think of anything against it.

Maybe they want to control the code that comes into their repo, but they could enable reviewers for that, so the pull will need to be approved by certain people before it gets merged. 

I'm afraid you'll get a better response if you ask them directly, as they could have some reasons, or maybe be unaware on some of the features they could use to control the code.

Let us know if you need anything else!

Cheers,

Ana

When I ask them they simply ask why they should get our commits. When I explain they say it doesn't matter. They did give us access once but then restricted it after pulling in our commits and deploying them to their site. It's really weird.

Hi Dave, I'm not sure I understand correctly, it looks confusing. 

My understanding right now is that you got a copy of someone else's repo, then you tried to push your commits to their copy of the repo, but they said that they don't want your commits. Is this right? In this case, they should restrict access to their repo, and then explain to you how would they like to collaborate with you, in case that was the purpose of sharing the repo with you.

If they already tried restricting the access but you're still able to push your code to their repo, then there's a problem: they either didn't do it correctly or there's some kind of issue with the permissions. We could have a look at that but we'd need the name of the accounts and the name of the repos. 

Cheers!

Ana

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

651 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot