It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Commits not Showing as Links to Jira

Tim McConechy Nov 12, 2014

Hi All,

We used to have JIRA (older 5.1) connected to Stash 3.2.2 and it worked. When committing we quoted the JIRA ticket and a link would be shown in the commits screens of stash to the Jira.

Now suddenly this is not working and the links all show as plain text. We still have the link established in JIRA (its a one sided link). So that part seems ok and I can see the data in JIRA and Stash but not the other way.

Was there some other place I should configure this linking I am forgetting about? Or what else could be wrong?

Thanks

 

6 answers

1 accepted

1 vote
Answer accepted
Jobin Kuruvilla [Go2Group] Community Leader Nov 12, 2014

Do you still have the application link from Stash to JIRA? Check under Administration > Application Links in Stash.

1 vote
Thiago Bomfim Atlassian Team Nov 12, 2014

Hi Tim,

As the new release of Stash and JIRA have come out, new versions of the AppLinks were shipped with newer releases of these products.

The solution here is to create the AppLinks from JIRA instead (as it contains the oldest version of the AppLinks library).

On the document below we have a version matrix of the minimum release required to support each one of the new integration features we've been shipping. If you want to keep up to date with those, I recommend you upgrade your JIRA as well:

Best regards,
Thiago Bomfim
Atlassian Support

 

0 votes
Mike Friedrich Nov 12, 2014

You should check you application link settings on both ends (incoming and outgoing).

It would be also helpful if you post your settings for these.

0 votes
Mike Friedrich Nov 12, 2014

I doubt its this, but you can also check time drift between the servers. Applinks require the times differences to be within 5 minutes.

0 votes
Tim McConechy Nov 12, 2014

On stash there is no app link. I swear there was one, but i don't really recall. When i try to create a Link it says that the JIRA is too old and makes me link only in JIRA (which is there and seemly working). This makes me think i cannot establish a link on this end. Showing:

 

The remote application, ' XXJIRA', is running an older version of the Application Links plugin. It will not be possible to create the remote end of the link from this application. However both ends of the link can be created using the older process in 'XX JIRA'. Alternatively click Continue to create the local end of the link only.

Do you think thats the issue, should i just hit continue and make it on the stash side? Just basically asking what configuration would be setting this on the stash side?

 

0 votes
Tim McConechy Nov 13, 2014

What worked was recreating the App Link on the Stash Side. This relinked everything. I was worried about doing this because of the warning saying it wouldnt work but it did cause stash to link all the items back to JIRA even tho the real link and integration is on that side.

Thanks!

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

3,126 views 1 22
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you