Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,529
Community Members
 
Community Events
168
Community Groups

Commit notifications not working

Edited

I've been fighting this for a couple days now.

 

Our "main" BB account has the team and repositories associated with that team. I've checked that all repo's are being watching and notifications and email is all turned on.

On my account, notifications and email is all turned on.

I've made dozens of dummy commits. They are getting record in BB just fine and display on screen for all accounts. Nobody gets notifications! Not even the team owner, repo owner, nobody.

What do I need to change to get this working?

 

Thanks :D

4 answers

1 accepted

0 votes
Answer accepted

No, no commit messages are getting to the Exchange server. Marketing emails from BB and Atlassian are coming in fine though, not hitting spam (first place I checked).

The messages are not getting generated.

I'm on the free plan ATM. Don't know if that makes any difference. Have run through the sestup wiki many times. Everything is turned on, but no messages.

More worrying.....just deleted 5 repositories and didn't get a single message!

Have un-watched and re-watched all remaining, several commits, nothing.

I think something is seriously broken here!

Support@bitbucket.org sent me the following possible fix

 https://bitbucket.org/site/master/issues/16313/unable-to-receive-commit-notification

In order to verify that you are indeed being affected by this bug and circumvent around it:

  1. Go to the Team account's settings (https://bitbucket.org/account/user/pcpl_dev_team/)
  2. Click on "Labs" under "Integrations and Features"
  3. Disable the "New source browser experience
  4. Check to see if the notifications work now.

 

It did not work! Notifications are still not being sent.

After several messages from tech support (grainy clips of a settings window) I have finally figured this out.

 

AFTER you watch and idividual repository, you then have to click the tiny "watch" icon again and enable the notifications you want to receive.

If you don't....you get nothing!

I highly suggest turning them ALL ON BY DEFAULT! Forcing the user back i nthere to disable what they don't want.

Notifications working, issue resolved.

Our team was just hit by this.  In the new Browser Experience, the 'Overview' tab did not exist for us.  Therefore, we were unable to select the 'commits' notification.  It was only after we disabled the Labs -> New Browser Experience that going into any repo allowed the 'Overview' tab to exist again.  Hopefully this can help someone as it has been driving us nuts.

Thanks for the answer. It really helps!

Thanks @njackowski, your suggestion got me back the ability to enable commit notifications.

I am using bitbucket server v6.3.2 and I do not see "Labs" or "Manage notifications" options. I am also receiving no notification after a commit. I dont want to hijack this thread so my question is at, https://community.atlassian.com/t5/Bitbucket-questions/Not-getting-notification-for-commits-to-repositories/qaq-p/1131439

Just tested. Notifications not working.

Hey Rana, 

Double check your spam filter in the (unlikely) event they are turning up there.

Then there are 3 things you have to do (which is dumb!)

1. Click the little "person" icon lower left, go to Bitbucket Settings>>Notifications and check they are enabled

2. Go to each repo an make sure you are watching them (again, dumb, why would I not be watching a repo I created! Counter intuitive)

3. Then go back in, click the tiny little eye icon top right which will bring up a menu you cannot access anywhere else… (repetitive, but must be said, dumb) ...and turn ON what notifications you want to receive. Again, I created it, why would I NOT want these on by default!

Having done all that, you have a 50/50 chance of getting them. I get about half of what I should. Some days a repo will send everything, the next nothing.

I was hoping Bitbucket was going to be a good replacement for GitHub. UI learning curve is to painful. Documentation is inadequate. Even the help desk "screen clips" are so grainy and out of context they are little help.

Hello, Thanks a lot for the response. I was missing number 3 from your list.

Although it was showing watching eye icon but the options underneath was unchecked.

I have made changes and replied to your post. Hopefully it should work now.

Thanks.

I've started seeing the same behaviour. For some reason bug reports are not automatically being set to be watched. I haven't changed any settings so something else must be up. Probably time for a bug report.

The same is here, no notifications on commits, but notifications on "My access to a repository or a team changing" f.e. are comming ok. I can't understand how to find "click the tiny little eye icon top right", the only little eye is in "Manage watched repositories":

_notifications_.png

and clicking it, repository becomes unwatched. So where I can find options: "and turn ON what notifications you want to receive"?

You need to go into the repo, summary view, in the top right corner is a tiny "eye" icon (watch/unwatch). When you click it a small menu appears showing all notifications settings for that repo. By default they are all OFF, turn ON the ones you want.

I've stopped using Bitbucket and moved to GitLabs. The UI is easier to understand and their documentation is superb.

Thank you for the answer! Unfortunately I can't see tiny "eye" in the top right corner :(. Checked both:

https://bitbucket.org/{user name}/{repo name}/src/master/

https://bitbucket.org/dashboard/overview

Don't know where to find it.. Meanwhile it seems GitLabs could be the answer..

Looks like another change in the UI that wiped out existing settings.

Bildschirmfoto 2018-07-30 um 12.52.46.png

Thanks, such a good-looking picture, it's a pity I'm unable to see it :(

Hoepfully this screenshot helps.

Bildschirmfoto 2018-07-31 um 11.18.02.pngFWIW I don't think the GitLab UI for watching notifications is any better. I actually like the Bitbucket UI and my problem was with a change made by Bitbucket to my notifications with no explanation. But I don't think this should really matter when choosing somewhere to host you project. The overall environment, but also the financing of the company and the T&Cs, are much more important and one of the reasons that I personally prefer Atlassian over, say GitHub. But, for example, I know several companies who love being able to run GitLab on their own equipment. In other words: don't just follow the crowd.

As regards GitLab, yesterday I've tried to import repo from bitbucket. I configured email notifications almost immediately in there and they are really working.

Thanks for the screenshot provided, but I can't find it. Couldn't it be possible that you are using Bitbucket server, while I'm trying to find this option in BitBucket Cloud? If it is Bitbucket Cloud in your case too, could you please provide exact url of the page?

@CharlieCposted an image (above) of the "Overview" page. The "eye" is at the far right.

Yes, this is cloud UI. When you click it, a small sub menu pops up (aysnc) displaying the options shown in the large screen shot.

If you don't see this tiny eye on the overview page, disable any plugins for your browser. If that doesn't help, install Edge or Opera as I know it works fine in either of those.

If you still don't see it, you didn't create the repo and do not have perms to change this setting. Contact the account owner and have them change it.

It seems I simply can't get to that "Overview" page. I've just created test private repo "testhg", as I understand clicking on its picture I should go to "Overview" page, but instead it shows something like:

https://bitbucket.org/{username}/testhg/src/default/

This is "Source" page, not "Overview". Moreover going to "Settings->Repository details" and changing "Landing page" from "Overview" to "Source" and saving repository details, I can check that clicking on repo image I'm still "landing" to: https://bitbucket.org/{username}/testhg/src/default/

While f.e. changing "Landing page" to "Downloads", I'm starting to land to:

https://bitbucket.org/{username}/testhg/downloads/

and the same different addresses for other landing pages, except "overview" and "source"..

I've tried this in Private window of Edge, Chrome and just installed Opera -> got the same results. It is just interesting for me, what is wrong in here..

Email notifications not working for me either. It was working fine just few days ago. I have changed my account email address and it stopped working. I have disabled the settings as suggested above. I will update if that make any difference.

0 votes
jredmond Atlassian Team Jun 07, 2018

Can you confirm that the messages are getting to your mail server? Are they being filtered as spam, or delivered to a folder other than the inbox, or otherwise not going where you were expecting to see them?

Hasn't been working for about 2-3 weeks now for me also

Screen Shot 2018-06-08 at 7.42.36 AM.png

jredmond Atlassian Team Jun 08, 2018

I have the same questions for you - are the messages making it to your mail server?

Yes, they are. In fact, I get notifications for commits into older repositories just fine. This repo is new and no notifications.

This is not working. The accepted answer is wrong.

This is not working for me either. The messages stopped working about 6 weeks ago.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events