Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,509
Community Members
 
Community Events
176
Community Groups

Change MTU for Bitbucket Pipelines Docker Daemon

I'm running the Bitbucket Pipelines Runner in our Rancher based Kubernetes cluster. It registers well, and I am able to run basic Pipelines and everything is going fine until some steps of the Pipeline has to download a large file. (In our case it was npm install)

I tried to search everywhere and I found a possible issue with network MTU.

The MTU size on the server is 1500, but the Kubernetes Network Provider is using 1450. I tried to update DIND to use the following settings:

- name: docker-in-docker
image: docker:20.10.7-dind
args:
- "--mtu=1300"

Now if I attach to the Bitbucket Runner container (atlassian/bitbucket-pipelines-runner), I can see the following setting in `docker network inspect bridge`:

./docker network inspect bridge | grep mtu
"com.docker.network.driver.mtu": "1300"

 Sadly if I attach from here to a pipeline container (or the atlassian/bitbucket-pipelines-docker-daemon container) I will still see the original:

docker network inspect bridge | grep mtu
"com.docker.network.driver.mtu": "1500"

 

Is it possible somehow to change the MTU for the bitbucket pipelines docker daemon?

 

Regards,

Janos

1 answer

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events