Change Bamboo plan repository to git makes it queue endlessly

Hello everyone,

We're in the process of migrating from Subversion to Git and are running into some issues with Bamboo. I updated the "Source Repository" for a plan and change the "Plan Repository" (default one) to Git. However, as soon as I try running a build, the build stays queued forever. It's stuck right before the point where it would clone the repository.

I've tried using the read-only git:// URL, the https:// URL and git-ssh. I'm able to clone the repository locally as the user that runs Bamboo. I've also successfully change to Git on other repositories, however, this is the second repository that has run into this issue.

I've tried reverting the Plan back to Subversion and it's experiencing the same behaviour. It feels like this entire plan is busted :(

Any help would be greatly appreciated. Thank you.

All the best,

Arthur Maltson

3 answers

1 accepted

Hi Arthur,

Sorry to hear that you are having trouble. This certainly shouldn't happen. What Bamboo version are you on? Have you contacted support?

Thanks
James

Hey James,

It's Bamboo 4.3.1 build 3400. It turns out that hitting the "stop all builds" on the build plan resolves the issue. The build "ends" and the "real" build starts> It continues to work afterwards. We haven't had this particular issue again.

We're having other issues with the branch based builds that we'll have to file an issue with Atlassian. Thanks.

Same problem here with Bamboo version 5.9.3 build 5918.

I've come across the same issue. What I have found in my situation that a hang occurs while awaiting authentication via SSH (but bamboo won't tell you this).

My solution involved uploading the SSH key and passphrase. If you change the git repo, even just adding a prefix ssh:// try re-adding the ssh key and passphrase again.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

24,306 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you