Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cant delete Project that has no Repositories Edited

I have a Project called "Untitled project".  The Project page says

"A new home for your brilliant idea

Now that you've got a project, let's bring in some repos and get cracking."

There are NO repos.  

I click on "Project settings" and then click on "Delete project"  but the pop-up says

"You cannot delete this project because it still contains repositories. To delete the project you must first move or delete any repositories."

Any thoughts on what I am doing wrong?

2 answers

1 accepted

2 votes
Answer accepted

I think I have worked out what the problem is.   I found a repository created using Mercurial. BitBucket no longer supports Mercurial repositories. So the repository cannot be deleted (and isn't even listed if you go into the Projects listing).  As a consequence, the project itself cannot be deleted.

Dave Liao Community Leader Nov 17, 2020

Whoa, good sleuthing! I can escalate this to Atlassian Support to help delete your project - unless you already have an open support ticket with them?

Thanks Dave - that would be great (I will have to learn how to create a ticket!).  I have no need for the old mercurial repository. It will have nothing of value in it.  It would have been created when I first dabbled in using Bitbucket  (I have been using Mercurial - via TortoiseHg  for some time  - obviously I am revisiting BitBucket to try and conquer my fear of the unknown.)

Like Dave Liao likes this
Dave Liao Community Leader Nov 17, 2020

Escalated!

Like Brian Goulter likes this

Just fyi    the name of the repo that can be deleted  is bbs_82f755_hg 

From my (failing) memory, the bbs  stood for Bridge Bidding Systems. I play bridge and was creating a database of various systems (what bids mean etc).   But I will have that info elsewhere.

Like Dave Liao likes this
0 votes
Dave Liao Community Leader Nov 17, 2020

@brian_goulter  - that's a weird one.

Try associating a repo to your project, then un-associate that repo. Then try deleting the project again?

Hi Dave

Thanks for the answer (and as you were writing your answer, I think I found the cause of the problem).

I had already tried your suggestion (made a repo, removed it so that again there were no repo's listed).

But this is the sort of "try this ..." suggestion that us newbies need.

Like Dave Liao likes this
Dave Liao Community Leader Nov 17, 2020

Obviously a reply like mine shouldn't be the answer long-term. ;-p

From my experience,   I try a dozen different things.  Finally, something works,   but then I can't work out which of the things I did were necessary  (and did they have to be done in a certain order...).   It makes it hard to offer recommendations to others!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

2,585 views 1 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you