Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,368
Community Members
 
Community Events
177
Community Groups

Cannot read from repository with publickey

I have setup my personal account as a member of a workspace. I can browse the repos in the workspace within the browser. I also added an SSH key to my personal account. Running "ssh -v git@bitbucket.org" works and says something like "You can use git to connect to Bitbucket." But when I try to clone the repo I get the error "git@bitbucket.org: Permission denied (publickey)".

Accessing the same repo from another account (obviously with a different SSH key) works without any problem.

Do you have any ideas?

1 answer

0 votes
Mark C Atlassian Team Mar 08, 2022

Hi @Martin Fuhrer

Welcome to the community.

To make sure your SSH key is in use, would it be possible for you to add it to your SSH agent?

eval $(ssh-agent)
ssh-add <Private SSH key location>

Once done, try to clone again.

If the issue still persists, you can try to enforce your environment to use a specific SSH key identity by adding the configuration below in your SSH config file.

Host bitbucket.org
  HostName bitbucket.org
  IdentityFile <Private SSH key location>

If you don't have the SSH config file yet, you can create it first:

vim ~/.ssh/config
chmod 600 ~/.ssh/config

Hope it helps and let me know how it goes.

Regards,
Mark C

Hi Mark,

Sorry for late answer, the move to bitbucket cloud has been postponed for some time. But now I'm ready to tackle it again.

Meanwhile I also found the problem. I had my .ssh folder in my Windows home folder, but git bash was using a different folder as home. After moving the keys there everything worked fine.

Like Mark C likes this
Mark C Atlassian Team May 30, 2022

No worries at all @Martin Fuhrer

Glad to know that after moving your keys, everything worked fine.

Do let me know if you have further questions that I can help with.

Regards,
Mark C

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events