Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,332
Community Members
 
Community Events
176
Community Groups

Cannot push to repository - access rights

I stating work on an existing project and my Atlassian account has have been added as an Admin to the repository and my SSH public key from my development laptop has also been added to the Access Keys list.

I tried to push up a new branch to the repo and receive this error (I've tried from command line and from Sourcetree - same result):-

Unauthorized
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

 

NB: I have cloned the repo via SSH with no problems so read access is fine...

Any ideas on how to fix this?

Thanks

1 answer

0 votes

Hello @06tech

Welcome to the Atlassian Community!

Access key in the repository provides READ-only access. Could you try adding the public SSH key in the Personal settings of the Bitbucket? 

Reference: https://support.atlassian.com/bitbucket-cloud/docs/set-up-an-ssh-key/

I hope this helps.

Kind regards,
Karthick S

Thanks for your reply - when I try and add my SSH key to my account through Personal Settings I get an error:-

 

Someone has already added that key as an access key to a repository.

Karthick S Atlassian Team Apr 10, 2022

Hello @06tech

Currently, it is not possible to add the same SSH key more than once. I believe you have mentioned you have added the SSH key in the repository as an access key. If yes, could you please remove it from the repository and then try adding the SSH Key in the Personal settings of the Bitbucket? 

Kindly keep us posted if you face any issues.

Kind regards,

Karthick S

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events