It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot merge pull request with REST API due to a permission problem

Marcin Kalinowski Nov 23, 2018

I have a master branch with merge permissions being set to only pull request only, with only a handful of users authorized to merge said pull requests.

The problem is that I am trying to automate delivery process, but I cannot merge a pull request into master with the /merge/ endpoint. The error I get is 400 - "merging a pull request requires write on origin and read on fork"

The setups tried are as follows:

1) OAUTH Consumer from the Team repository

2) OAUTH Consumer from my own user (who is explicitly stated that I am able to merge into master)

Now, if I authorize everybody to merge pull requests into master, REST API endpoint works fine. But I cannot leave it at this.

 

1 answer

0 votes
Ana Retamal Ortiz Atlassian Team Nov 26, 2018

Hi Marcin

Can you share the code you're using so we can have a look?

Have you tried with any of the other authorized users and are getting the same error?

Let us know!
Ana

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

1,613 views 1 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you