It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't login to bitbucket

Viewing page 2 of 2

27 answers

Having a similar problem recently in Visual Studio 2017 Enterprise. I can browse fine to my BitBucket repo in Chrome, but when I try to push my local commit the BB login screen pops up. Despite entering valid credentials (numerous times) it fails:

Remote: Invalid username or password. If your organization manages your account or you've enabled two-step verification, create an app password to log in: https://confluence.atlassian.com/x/9DJmMQ
Error encountered while pushing to the remote repository: Git failed with a fatal error.
Authentication failed for '<the name of my repo>'
Pushing to <the name of my repo>

Repo name is in format
https://bitbucket.org/<username>/<repo>

 

If I do the push via git command line it pops up the (white) login box and it then works...

Hi Alastair,

I saw that but I'd rather not reset my password.. The credentials I have work fine via git command line, just not in Visual Studio.

Oh, you should be able to skip that step. The key thing in those steps is to clear your local stored credentials.

Typically its working fine at the moment - I'll try that if it happens again, thanks :).

I tried this and did not work.

I cannot push sync through Visual Studio.

If I push from the command line it pops up the Atlassian dialog box to enter username and password. It still sees my username "first_last". When I try to log in, it fails. When I change the username to "first_last"@hotmail.com, it fails as well.

When it it prompts me for my password in the command prompt it says "Password for 'https://first_name@bitbucket.org". When I put in my password it then works and pushes.

So I have no idea why it's not pushing through Visual studio nor why it fails to accept my credentials when it pops up the Atlassian box.

This is annoying.

Same problem here. I have tried to clear credentials in windows, but this does not help.

This seems to be even worse with the latest VS patch - I feel its VS's fault in this case as command line works fine. See this thread here for more details:

https://github.com/github/VisualStudio/issues/949

This was mentioned above in another comment (thanks!) but I'll add it here:

Updating to the latest version of Windows Credential Manager should fix this issue. https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases

I've removed all entries regarding Git or Bitbucket from Windows Credential Manager and then I've performed the following.

1. download the zip (not the exe) file gcmw-v1.17.0.zip from https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases
2. navigate to C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\CommonExtensions\Microsoft\TeamFoundation\Team Explorer\Git\mingw32\libexec\ (or wherever your 'missing' git-askpass.exe resides).
3. make a copy of the git-core folder and rename it backup or something like that
4. put the files from the zip file on top of the contents of your new git-core folder and overwrite where prompted

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Bitbucket

Share your software development horror stories!

Hey Community! I work on the Bitbucket product marketing team. With Halloween approaching, we wanted to discuss a topic tailor-made for October: development horror stories. Whether it was a lurk...

1,020 views 11 2
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you