Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,366,357
Community Members
 
Community Events
168
Community Groups

Can't login to bitbucket

I can't login to bitbucket. I have error message either "Invalid username/email or password." or "You can't use that email address to log in. Use your Atlassian account email address instead.". But I'm using my Atlassian email address, when I recieve second error message

30 answers

Absolutly ridiculous. Have a push pending and can't do it because there's no way the password is accepted.

This is just absurd

For those struggling with Git, Bitbucket and Windows authentication, try installing the latest Windows Git Credential Manager: https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases

Thanks! Installing 1.17.1 fixed it for me.

I had previously tried

  • deleting bitbucket credentials from the credential cache as well as
  • logging out and back into bitbucket in the browser.

After this I was able to use the username in my bitbucket username login that pops up.

Via chocolatey I have (latest)

  • git 2.18.0
  • gitextensions 2.51.4

 

Cheers

Like # people like this

thanks worked for me too

v1.18.3 worked for me. Thanks

Works for me too. Thank you!

Like emmyle likes this

What a MESS !. Probably will switch to github

After merging with Atlassian Account, I keep having issue to login bitbucket.

It keep prompting The email address or password you entered is incorrect.

But my email and password can login to Atlassian, but not Bitbucket.

In order allow me to login, I use the following step:-

1.When I try to forgot/reset password, it ask me.

It looks like you're using an Atlassian account!

To get back into Bitbucket, you'll need to reset your Atlassian account password.

The problem is Bitbucket not my Atlassian.

**I am sure which team should fix the bug, but definitely need to do something

 

In order for me to continue login.

2.I click "Continue" button.

3.It redirect to Atlassian reset your password page

https://id.atlassian.com/login/resetpassword?application=bitbucket&continue=https%3A//bitbucket.org/socialauth/login/atlassianid/

4.Return to log in

5.https://bitbucket.org/socialauth/login/atlassianid/

6.tata, Then I am login.

I can't use my Atlassian email and password direct login to from Bitbucket login page.

 

 


This still does not allow cloning of Bitbucket repos- only useful for login from website.

Like Nandhakumar likes this

I was redirected to id.atlassian.com when tried to log in to my bitbucket account.

I tried to provide my bitbucket credentials at id.atlassian.com but it said they're incorrect.

Then I managed to registed a new account at id.atlassian.com for the same email address as on bitbucket.

But I ended up with two different profiles: this one, which has no access to my bitbucket projects (however now I can use it to post about my problems here lol), and my old bitbucket account which I can still access in a different browser where I already logged in at bitbucket.

IT IS VERY FRUSTRATING THAT ATLASSIAN IS TRYING TO EXPAND INSTEAD PAYING MORE ATTENTION TO THEIR PRODUCTS QUALITY

Hi Aliaksandr,

Sorry for the inconvenience. It's probably best you file a support ticket at http://support.atlassian.com/bitbucket-cloud so we can help you personally. Thanks.

Alastair

I fixed my issue by changing the email-address of the Atlassian Account to the one of the Bitbucket Account (before the merging). .. I used my university address for Bitbucket and private one for Atlassian...

Don't know if this helps..

I was having the same issue, but managed to work my way around it by logging in using the Login with Google option.  I created my account before Bitbucket transitioned to using the Atlassian Account for signin, and I must have created it using the Signin with Google option.  When it transitioned to Atlassian Account, I was prompted to create an Atlassian account, which I did, but have never been able to login to Bitbucket using those credentials.

This was a workaround for me logging into the website, but I don't think it fixes the issue of doing pulls/pushes using https (I use ssh keys).

Hi Brian,

Thanks for your answer. We really want to get to the bottom of this - if you have a chance, could you email support@bitbucket.org with your account details? It would be very helpful - thanks!

Alastair

Were you able to fix this? I am having the same issuee

got the same issue

When I tried to clone a bitbucket repository, an atlassian pop up asked me for my credentials (Microsoft credentials) and rejecting them. The solution was to create an App Password and log in with my username and the generated password.

You may come across login issues with Sourcetree once in a while. When that happens, login is always failing despite using the correct username and password. There can be a number of reasons for this. One of the reasons may be that Sourcetree fails to complete the authentication process using the provided credentials.

The authentication process will open your default web browser and eventually make a HTTP redirection to localhost with a URL that looks like

http://localhost:34106/?state=authenticated&code=XXXXXXXXXXXXX

Based on the redirection URL, Sourcetree needs port 34106 on your local machine in the authentication process. It will attempt to open the port during authentication. This port may not be allowed due to local firewall rules. To overcome this, simply check and configure a firewall rule for port 34106 to be allowed for Sourcetree and re-attempt the login.

If it still fails, replace localhost with 127.0.01 in the redirection URL on the browser like

http://127.0.0.1:34106/?state=authenticated&code=XXXXXXXXXXXXX

and refresh.

Hope it helps.

I suspect during installation of Sourcetree, it fails to register a firewall rule for the port.

I cant login to my bitbucket account

I login with current account as usual
fill email and changed password
then i see screen with fields - Add your unique path on page https://bitbucket.org/socialauth/signup/?next=/
i added name of my current account
and see error label "That username already exists"
i tryed to change this name in field and login to bitbucket as new account with my current email without any my repositories

I've removed all entries regarding Git or Bitbucket from Windows Credential Manager and then I've performed the following.

1. download the zip (not the exe) file gcmw-v1.17.0.zip from https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases
2. navigate to C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\CommonExtensions\Microsoft\TeamFoundation\Team Explorer\Git\mingw32\libexec\ (or wherever your 'missing' git-askpass.exe resides).
3. make a copy of the git-core folder and rename it backup or something like that
4. put the files from the zip file on top of the contents of your new git-core folder and overwrite where prompted

Having a similar problem recently in Visual Studio 2017 Enterprise. I can browse fine to my BitBucket repo in Chrome, but when I try to push my local commit the BB login screen pops up. Despite entering valid credentials (numerous times) it fails:

Remote: Invalid username or password. If your organization manages your account or you've enabled two-step verification, create an app password to log in: https://confluence.atlassian.com/x/9DJmMQ
Error encountered while pushing to the remote repository: Git failed with a fatal error.
Authentication failed for '<the name of my repo>'
Pushing to <the name of my repo>

Repo name is in format
https://bitbucket.org/<username>/<repo>

 

If I do the push via git command line it pops up the (white) login box and it then works...

Hi Alastair,

I saw that but I'd rather not reset my password.. The credentials I have work fine via git command line, just not in Visual Studio.

Oh, you should be able to skip that step. The key thing in those steps is to clear your local stored credentials.

Typically its working fine at the moment - I'll try that if it happens again, thanks :).

I tried this and did not work.

I cannot push sync through Visual Studio.

If I push from the command line it pops up the Atlassian dialog box to enter username and password. It still sees my username "first_last". When I try to log in, it fails. When I change the username to "first_last"@hotmail.com, it fails as well.

When it it prompts me for my password in the command prompt it says "Password for 'https://first_name@bitbucket.org". When I put in my password it then works and pushes.

So I have no idea why it's not pushing through Visual studio nor why it fails to accept my credentials when it pops up the Atlassian box.

This is annoying.

Same problem here. I have tried to clear credentials in windows, but this does not help.

This seems to be even worse with the latest VS patch - I feel its VS's fault in this case as command line works fine. See this thread here for more details:

https://github.com/github/VisualStudio/issues/949

This was mentioned above in another comment (thanks!) but I'll add it here:

Updating to the latest version of Windows Credential Manager should fix this issue. https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases

I had a similar issue and was unable to push or pull in my code editor, but could log in to either site.  I had contacted support at BitBucket, and they resynced my account, to no avail.

The solution at the following link worked for me (apparently things were cached on my machine):

https://confluence.atlassian.com/bbkb/authentication-error-remote-invalid-username-or-password-942864127.html

I have a similar issue; until yesterday; I was able to navigate the web, commit using TortoiseGit no issues;

Today morning pop-up appears asking me email/user-name and password; using the same email and password I use for Atlassian account which is managed by Google.  Fails all the time

I already tried reset password but in vain; redirects me to Atlassian password reset page from where I receive the email and this does not ask me new password instead logs me back in successfully; Which is correct as my Atlassian account is hooked to Google

If I log out from Atlassian and sign back in using Google authentication and navigate to bitbucket; it's fine

But cannot use the same credentials to perform GIT operations via git commands or tortoise git or Sourcetree (tried boh email and bitbucket user name)

Error snapshot is as follows

login.PNGcommit error.PNG

BTW; I am posting this using the same account

Fix it ASAP

I found a workaround

Cancel login prompt, this will show up old not supported username and password prompt, here use your bitbucket username followed by the password

 

Capture.PNG

Unfortunately, you will have to perform this operation for all command

Come on Atlassian. Send an update to make this work again. Gosh.  I'm seriously wanting to give up on this.

I have fixed the problem by logging in Bitbucket again. I see two login interfaces of this page when logging (one blue and one white).
When I login in them, I see two different paths. One of them is correct.
I think it is the mistake of Bitbucket and I hope it 'll be fixed soon.1.PNG2.PNG

Tài,

Both paths should work. Which one isn't working for you?

Thanks,
Alastair

I have previewed two paths, and they 're here

https://username1@Bitbucket.org/project/project.git
https://username2@Bitbucket.org/project/project.git

Both of them are ok in the web and source tree, but if you use Android Studio to clone you must change the username you login.

It's absurd that in 2018 Atlassian still has this half-baked sso setup where you have to go through 5 accounts and 20 captchas and still not be able to do a simple git pull. This is frustrating.

The same happen here

the weird thing is I can login to write in this forum using the reseted password for bitbucket, but cannot login to bitbucket.

let alone clone push etc to repository in bitbucket.

hope this problem cleared soon.

This is killing me today.  I can't get my code up to the team.

Weird thing happen, I try to clone and login to bitbucket account with the same user and pass I used before (which is not working) now it working. Well I did sent an e-mail to support@bitbucket.org to see this page. and that the only thing I do beside writing in this page.

Worth to try?

Try SSH access. Worked for me.

Now in my case because of this issue, I cannot take a pull from my repo. It says its wrong password when i try to do a git pull.. but i can login to atlassian and get back to bitbucket web using same creds.

More importantly i cannot login directly using email and password to bitbucket but can use same username and password i can login to atlassian. I can use signin with google option on both thee application and its working fine. 

Can someone tell me how to fix the issue of git pull ?

I have the same problem here.FRUSTRATING. How to fix this?

This continues to happen. The problem is the Google login. 

I got the same problem. I couldn't log in to HipChat or Bitbucket, but I was sure I had the right password. I had logged in only a few days previously without issue, and I got the password stored in a password saving application. I couldn't understand it.

I finally fixed it after finding this thread and seeing that people had to create an Atlassian account. I already had one, so I tried logging in to that. I was immediately told that my password had been reset, and I should check my emails and then I had to set a new password. After this, I could log in to HipChat and Bitbucket with my new password.

There was absoluitely no indication that this was the case when trying to log in to HipChat or Bitbucket. It just told me that I had an incorrect username or password, but I knew it was correct. Infuriating.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events