Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,112
Community Members
 
Community Events
176
Community Groups

Can't find a root directory while resolving a config file path on Jest tests.

Edited

On test pipeline using default bitbucket-pipelines.yml i'm getting the following error:

 

Error: Can't find a root directory while resolving a config file path.
Provided path to resolve: test/config.json


What could I do?

2 answers

1 accepted

0 votes
Answer accepted

Solved. It was a mistake.

What was the mistake? I'm likely making the same one :)

Ya, post the solution. I'm hitting this error. I added a file to the list of setupFilesAfterEnv and now running into this

The file exists. I can't see any obvious link between adding a file to this config entry and suddenly not being able to determine the root dir

This project is from years ago. Seeing the only project that runs jest I needed to set --config flag on the npm test task. In that case, this points to test/config.json.

Running it I don't see any problem.

@Declan Shanaghymaybe seting the --config option solved the issue. If you have any problems after this, try open an issue.

Thx. I do have the `--config` option set. Must be something else :-(

The silly mistake I was making was feeding in `--config jest.config.json` when my config file was actually js. Worth checking if google brought you here ;)

Thank you 😅

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events