Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Can't clone repo within a pipeline that runs on a self hosted runner


I'm having a hard time understanding an issue that happens when I run a pipeline on a self hosted (linux) runner.

I get the following problem during the `Build setup`,


 Cloning into '/opt/atlassian/pipelines/agent/build'...
fatal: unable to access '': Recv failure: Connection reset by peer


I've checked that I have access to internet (can curl to bitbucket and atlassian sites without a  problem)

2 answers

2 votes
Patrik S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 31, 2023

Hello @Rafael Soares Pinto and welcome to the Community!

Based on the error message you received, this seems to be a connectivity issue from the runner's host to Atlassian infrastructure.

This is usually caused if your runner's host is behind a firewall/proxy that is blocking the connection to Atlassian.

In this case, I would suggest you confirm if all the IPs listed in Valid IP addresses for are allowed in the firewall, as the connection to those IPs is necessary for the self-hosted runner to clone the repository.

You can also try executing the runner in a different machine/network (your personal laptop, for example) and check if the same error happens.

Let us know in case you have any questions.

Thank you, @Rafael Soares Pinto !

Patrik S

Hi @Patrik S ! Thanks for you answer!

Using the same VM I switched to use the linux shell and it works perfectly, but I don't know why it did not work for docker runner.

I'm trying to host the runner on  a google compute instance. Previously I used the command

docker container run  \
 -v /tmp:/tmp \
 -v /var/run/docker.sock:/var/run/docker.sock \
 -v /var/lib/docker/containers:/var/lib/docker/containers:ro \
 --name runner-${RUNNER_ID} \
but it returned me the error i mentioned earlier.  I'm a little lost on this issue. Do I need to do an extra configuration on the compute instance?

Patrik S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 31, 2023

Hello @Rafael Soares Pinto ,

I'm not very familiar with the Google compute instance configuration, but this would lead me to believe a firewall (see Google VPC firewall) is blocking the connection to Valid IP addresses. Interesting though that with the shell runners in the same environment it did work.

Could you confirm if the host machine meets all the requirements listed in Prerequisites for linux docker runners ?

Also, if you try to execute the Linux docker runner on a different machine (outside of GCloud), does the same issue happen? 

Hi @Patrik S

I have found this issue only when executing the runner within GCLoud. When I run it on my personal notebook, it works without a problem. I also checked that all the prerequisites are satisfied.

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events