Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Can't clone my repo

I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 1, 2024

Hello I'm new to git & Atlassian and really want to have confluence & git under same account but I can't manage to clone my repository.

I've try to add an ssh keys, still not work

I've try to use the application password, still not work,

Frustrating because I see my repo an the clone button on bitbucket but no :(

The error that I've got :

Commande: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://<redacted><workspace>/<repository>.git 
Erreur: remote: Invalid credentials
fatal: Authentication failed for '<workspace>/<repository>.git/ '


Also got a question, I'm really not sure from where came this sufix (-admin) in my username? Not from me at least.

Thanks for any help.

1 answer

1 accepted

1 vote
Answer accepted
Patrik S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
April 2, 2024

Hello @Damien ,

and welcome to the Community!

It looks like you are using Sourcetree to clone the repository, so it may be an issue with your Sourcetree installation/configuration.

In order to check if Sourcetree is playing a role in this issue, I would suggest trying to manually clone the repository in a terminal session of your machine using the below command : 

git clone https://{username}:{app_password}{workspace}/{repository}.git


  • username : your bitbucket account username. You can check your username and edit if you want by navigating to your personal bitbucket settings
  • app password: a user-level token (not the password used to log in to the UI) used to authenticate git operations over HTTPS. If you haven't already, you can create a new app password under your account.

Could you try cloning with the instructions above and let us know how it goes? :) 

Should you have any questions, feel free to ask.

PS: To protect your privacy, I've edited your original question to remove the repository and username as this is a public forum.

Thank you, @Damien !

Patrik S

I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 2, 2024

Hello @Patrik S ,

Thanks for your answer, indeed I use sourcetree, though it will be simpler to use with bitbucket?

So I've install "git for windows", use your command, and I've manage to clone the repo.

Now I guess I have to find a way to add the repo on sourcetree, because really looking forward to use a gui git and not a terminal command.


Thank you also for the privacy cleaning.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events