Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Can't checkout master on a branch pipeline

I have a pipeline that runs when pushing to a branch. I created a manual step to merge that branch back to master. Triggering this step, checking out master always fails.

  - git remote set-url origin https://username:${GIT_SECRET}@bitbucket.org/custodyx/cxc
  - git remote show origin
  - git fetch origin && git branch -avv && git checkout master

Here's I'm using app passwords, but I tried SSH keys to no avail.

Output:

> git remote show origin

* remote origin
  Fetch URL: https://username:$GIT_SECRET@bitbucket.org/custodyx/cxc
  Push  URL: https://username:$GIT_SECRET@bitbucket.org/custodyx/cxc
  HEAD branch: master
  Remote branch:
    pipelines-merge tracked
  Local branch configured for 'git pull':
    pipelines-merge merges with remote pipelines-merge
  Local ref configured for 'git push':
    pipelines-merge pushes to pipelines-merge (up to date)
> git fetch origin && git branch -avv && git checkout master

* pipelines-merge                2685089 [origin/pipelines-merge] merge back to master
  remotes/origin/pipelines-merge 2685089 merge back to master
error: pathspec 'master' did not match any file(s) known to git.

* pipelines-merge: the branch to merge from

Any variation on authentication method & checking out produces the same result. It's like any other branches are invisible to the pipeline.

Is this expected? What am I doing wrong? Thanks in advance!

 

3 answers

1 accepted

2 votes
Answer accepted

I was able to reproduce the error locally. The culprit is the parameter `--depth`. Specifying `depth: full` on bitbucket-pipelines.yml should fix, but then this applies to all steps. I need to do this only in a single step.

Here is the solution on step level.


- step:
script:
- git fetch --unshallow
- git config remote.origin.fetch "+refs/heads/*:refs/remotes/origin/*"
- git fetch origin
- git checkout --track origin/master

I've found this on link

Also, there is the issue created for defining clone depth per pipeline

Specifying `depth: full` also work for me,

Thank you Andre

where do you set this?

This is an example:

clone:
  depth: full
  
pipelines:
  default:
    - step:
        name: Cloning
        script:
          - echo "Clone all the things!"

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events