Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,666
Community Members
 
Community Events
176
Community Groups

Can't authenticate with Altium software

Hi there! 

I want to use bitbucket to control version Altium files. I folowed the steps in Altium to configure all the steps but when I am asked for the username and password, after entering my credentials it "starts" to upload the files.. but after a couple of seconds stack at 0% it launches an error window that says:

Authentication failed for "https://myrepository..."

Invalid username or password

Details: too many redirects or authentication replays

 

I checked that I entered the credentials correctly (and definitely I did. I tried a lot of times) but nothing happens, always the same error. 

 

Any idea?

 

Thanks for the help

1 answer

0 votes
seanaty Atlassian Team Apr 07, 2022

A not 100% sure what's going on and need more information.

Do you have a link for to the Altium instructions for setting this up that you could share? (First time I'm hearing of this product)

Also, I suspect that the issue is that you can no longer user your "main" password to do anything git or API-related. Your "main" Atlassian password is only used for interactive login to the website bitbucket.org.

All that said, Bitbucket still supports git and API! You just need to create an app password for your account. Then you should be able to do the exact same thing you're doing with your username and your app password instead of your "main" password.

Here some other posts about the deprecation of the "main" password:

https://bitbucket.org/blog/deprecating-atlassian-account-password-for-bitbucket-api-and-git-activity

If you want to check more information about the App Password, you can reference this documentation.

Please note, that you need to enter the username, not the email ID. You can get the username from your personal settings

(Please accept this answer if it solves your problem ;))

seanaty,

 

I'm having difficulty with this too. I have an app password and I can push to bitbucket from tortoisegit, but not from within Altium. Do you see anything I have wrong?AltiumGitCred.png

Patrik S Atlassian Team Jul 26, 2022

Hello @Bob Kruse ,

Could you try creating a new app password with all the permissions checked and test how it goes? When copying/pasting the app password make sure there's no leading/trailing spaces

Also, please make sure to use your bitbucket username as the User Name field for personal settings.

In case the above does not work, could you share the full log output containing the error you are facing and also the result of when you click the "Test" button?

Thank you, @Bob Kruse .

Kind regards,

Patrik S

Thank you Patrick,

 

It failed again. This time with an all-permissions app password and my username.

This is the path to the source files:https://bitbucket.org/xxxxx/900831/src/master/

Where do I find the log files? I wasn't able to find one for Altium, but maybe there is one somewhere.

here is the test button output:

Thanks, Bob

AllPermissions.png

Patrik S Atlassian Team Jul 26, 2022

Hello @Bob Kruse ,

Thank you for sharing addittional context.

From your tests the credentials does not seem to be the issue here, and the fact that you are able to successfully clone/push from tortoiuse git indicates the issue is mostly likely with the configuration of Altium.

Checking the screenshot you attached though, it seems like you Altium configuration is considering the repository as SVN, instead of git, and this might be causing the error. This is also reinforced by the fact the error message when you clicked "Test" is not complaining about authentication but with the address of your repository.

As this is a third-party application, I don't really have much knowledge on how it's configured other than what I could find in Altium's documentation, so in this case I would suggest looking for any setting in the screen that you shared that allows to change the repository from SVN to Git.

If it does not work, I would recommend following the steps outlined on Altium's official documentation of how to integrate with a git repository.

Thank you, @Bob Kruse .

Kind regards,

Patrik S

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events