Can't access stash web interface after installation

Hi guys,

I decided to try STASH. Prepared CentOS 6.5 32bit VM with 2G RAM. Disabled Selinux and built git v1.9.
After that, I followed manual and reached step «open your http://localhost:7990».
So, I installed nginx, configured proxy. But when I see nothing when I open my http://git.servername.com.

in tcpdump I see answer like this:

0x0040:  251f 3aa0 4854 5450 2f31 2e31 2034 3034  %.:.HTTP/1.1.404
	0x0050:  204e 6f74 2046 6f75 6e64 0d0a 5365 7276  .Not.Found..Serv
	0x0060:  6572 3a20 4170 6163 6865 2d43 6f79 6f74  er:.Apache-Coyot
	0x0070:  652f 312e 310d 0a54 7261 6e73 6665 722d  e/1.1..Transfer-
	0x0080:  456e 636f 6469 6e67 3a20 6368 756e 6b65  Encoding:.chunke
	0x0090:  640d 0a44 6174 653a 204d 6f6e 2c20 3134  d..Date:.Mon,.14
	0x00a0:  2041 7072 2032 3031 3420 3131 3a30 373a  .Apr.2014.11:07:
	0x00b0:  3238 2047 4d54 0d0a 0d0a                 28.GMT....

Could anyone help, please?

3 answers

1 accepted

Thanks everyone for attention.

The trouble was in mc and long filenames. Everything become ok after I unpacked stash with tar -zxf.

Hi Pavel, we have this doc for configuring Stash with nginx. You may like to take a look at it and compare with your configuration.

Cheers

Thanks for your answer!

Actually I can't access to installation interface directly by ip as well. I tried with both Java: Sun and open.
Also I tried on 2 diffetent CentOS servers and got same result: 404 from Apache-Coyote server without any HTML page. BUT on Fedora everything is ok out of box!

All requirements are checked: Java 1.7, Perl 5.10, Git 1.9. No firewalls, no Selinux, started under root user, no error logs.

Can't imagine how to debug...

Did you try: http://git.servername.com:7990as the URL?

Assuming yes, is http/apache running on the machine? On our server, I had to manually start it and then add it to the system startup configuration.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

22,317 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you