Missed Team ’24? Catch up on announcements here.

×
Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

CI Pipeline hangs when using nx with max-parallel higher than 1

Johannes Fahrenkrug October 13, 2022

Hi,

I'm using Bitbucket Cloud to run the tests of an nx project.

When `max-parallel` is set to a value higher than 1, the pipeline times out. It seems as if Bitbucket doesn't notice that the command has finished. When I set max-parallel to 1, it works.

 

Here's my yml file:

 

image: node:16

options:

max-time: 20 # configure default 20 minute timeout

pipelines:

pull-requests:

'**':

- step:

name: 'Lint, test, and build'

caches:

- node

script:

- npm ci

- npx nx workspace-lint

- npx nx format:check

- npx nx affected --target=lint --base=origin/master --parallel --max-parallel=3

- npx nx affected --target=test --base=origin/master --parallel --max-parallel=1 --ci --code-coverage

- npx nx affected --target=build --base=origin/master --head=HEAD --parallel --max-parallel=3

 

When changing `max-parallel` in the second to last line to "3", the pipeline won't finish. When running it locally on my machine, it finishes just fine. Any thoughts?

2 answers

1 vote
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 14, 2022

Hi Johannes,

One possibility is that step may need more than 20 minutes to finish.

When `max-parallel` is set to a value higher than 1, is there any indication in the command's output that the command has finished doing what it is doing?

Is there an option to add verbose output to the command (that may show additional output about what is happening)?

Kind regards,
Theodora

0 votes
Melvin Williams
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 19, 2024

@Johannes Fahrenkrug  did you find a solution for the problem. I'm facing the same behaviour.

Johannes Fahrenkrug March 20, 2024

@Melvin Williams The only "solution" we found was to set `--max-parallel=1` when running our tests on the BitBucket pipeline. 

Melvin Williams
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 20, 2024

Thanks for the reply. Which Nx version are you using

Johannes Fahrenkrug March 20, 2024

16.6.0

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events