Bitbucket will not start after new Installation

We installed Bitbucket via the Linux installer and left all of the defaults. Git and all of the other prerequisites are already installed on the server.  Attempting to start Bitbucket using the service "service atlbitbucket start" results in an error message in the log file and then nothing more. The java process is up and running but the web application is never available. There are no issues with firewall or SELinux config. The following is the last message in the $HOME/log/atlassian-bitbucket.log.

2018-01-23 14:11:16,922 INFO [spring-startup] c.a.s.i.hazelcast.HazelcastLifecycle Updating Hazelcast instance capabilities
2018-01-23 14:16:03,819 ERROR [Caesium-1-4] c.a.scheduler.core.JobLauncher Scheduled job with ID 'IndexingAnalyticsJob' failed
rx.exceptions.OnErrorNotImplementedException: null
at rx.observables.BlockingObservable$8.call(BlockingObservable.java:642)
at rx.observables.BlockingObservable$8.call(BlockingObservable.java:639)
at rx.observables.BlockingObservable$9.onError(BlockingObservable.java:673)
at rx.internal.operators.NotificationLite.accept(NotificationLite.java:147)
at rx.observables.BlockingObservable.subscribe(BlockingObservable.java:528)
at rx.observables.BlockingObservable.subscribe(BlockingObservable.java:665)
at rx.observables.BlockingObservable.subscribe(BlockingObservable.java:639)
at com.atlassian.bitbucket.search.internal.analytics.IndexingAnalyticsJob.runJob(IndexingAnalyticsJob.java:51)
at com.atlassian.scheduler.core.JobLauncher.runJob(JobLauncher.java:153)
at com.atlassian.scheduler.core.JobLauncher.launchAndBuildResponse(JobLauncher.java:118)
at com.atlassian.scheduler.core.JobLauncher.launch(JobLauncher.java:97)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.launchJob(CaesiumSchedulerService.java:443)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeClusteredJob(CaesiumSchedulerService.java:438)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeClusteredJobWithRecoveryGuard(CaesiumSchedulerService.java:462)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeQueuedJob(CaesiumSchedulerService.java:390)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService$1.consume(CaesiumSchedulerService.java:285)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService$1.consume(CaesiumSchedulerService.java:282)
at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.executeJob(SchedulerQueueWorker.java:65)
at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.executeNextJob(SchedulerQueueWorker.java:59)
at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.run(SchedulerQueueWorker.java:34)
at java.lang.Thread.run(Unknown Source)
Caused by: com.atlassian.bitbucket.search.client.ElasticsearchClientNotConfiguredException: null
at com.atlassian.bitbucket.search.client.DefaultConfigurableElasticsearchClient.lambda$execute$2(DefaultConfigurableElasticsearchClient.java:35)
at java.util.Optional.orElseGet(Unknown Source)
at com.atlassian.bitbucket.search.client.DefaultConfigurableElasticsearchClient.execute(DefaultConfigurableElasticsearchClient.java:35)
... 14 common frames omitted

2 answers

1 vote

Hi Matthew,

The log lines don't explain why the application is not available in the user interface.

 

Are the CPU (2+ cores) and memory (3+ GB) requirements met on this server?

See Supported Platforms.

 

Cheers,

Caterina - Atlassian Support

Thanks for the reply. We were able to figure out the problem as a permissions issue. The error in the log file was a red herring as it is thrown if you haven't finished the bitbucket setup which we of course hadn't as the web server was not accessible.

Hi Matthew,

What exactly the solution to overcome this problem. I strucked at the same point and same error message. 

Make sure that the top level folder for the Bitbucket install (both install and data locations) is owned by the bitbucket user. If you followed the installation guide then the permissions on the top level folder should be set recursively for user atlbitbucket. That error message doesn't mean anything at the point of the install as it will be there since the Bitbucket setup has not been completed.

Great find Matthew, I agree.

Hi,

I got the same error and both folders home and data are owned by atlbitbucket recursively.

@Matthew McLeod Any other hints? Have you re-done the installation after changing these two folders owner?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

23,239 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you