Bitbucket service had crashed, after service reinstall Bitbucket keeps wanting to run setup

I had an issue with the Bitbucket services on a Windows 2012R2 server.  I had to remove the service using hte SC delete command and reinstalled the service.  Now when I restart the service it wants to run the setup all over again.  I tried the following from Atlassian support:

 

BITBUCKET_HOME may not be set correctly, causing Bitbucket to point to an empty home directory. This would trigger the first time setup.

You can correct the value for BITBUCKET_HOME by going to $BITBUCKET_INSTALL\bin\set-bitbucket-home.bat and modifying the line: 
set BITBUCKET_HOME=<your bitbucket-home path>

Make sure the path here points to the correct location, then restart Bitbucket Server.

 

But that's a no go, it doesn't work.  It still wants to run the setup. 

0 answers

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

638 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot