It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bitbucket server unable to push first commit

Hi community, I just installed Bitbucket 5.11.1 in a linux box, and I can't make it work...

I created a repo added my user to that repo, added my ssh key, etc.

When trying to push my first commit I am getting following error message:

- - -

$ git push -u origin master

Counting objects: 185, done.

Delta compression using up to 4 threads.

Compressing objects: 100% (183/183), done.

Writing objects: 100% (185/185), 35.48 MiB | 581.00 KiB/s, done.

Total 185 (delta 15), reused 0 (delta 0)

remote: Resolving deltas: 100% (15/15), done.

remote: Can't locate strict.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/lib64/perl5/IO/Handle.pm line 261

remote: BEGIN failed--compilation aborted at /usr/lib64/perl5/IO/Handle.pm line 261.

remote: Compilation failed in require at /usr/lib64/perl5/IO/Socket.pm line 12.

remote: BEGIN failed--compilation aborted at /usr/lib64/perl5/IO/Socket.pm line 12.

remote: Compilation failed in require at /var/atlassian/application-data/bitbucket/bin/git-hooks/hook-callback.pl line 15.

remote: BEGIN failed--compilation aborted at /var/atlassian/application-data/bitbucket/bin/git-hooks/hook-callback.pl line 15.

To ssh://mydomainnameserver:7999/~user/reponame.git

 ! [remote rejected] master -> master (pre-receive hook declined)

error: failed to push some refs to 'ssh://git@mydomainnameserver:7999/~user/reponame.git'

 

I am using a mac with High Sierra fully updated, git version in Mac 2.14.3 (Apple Git-98), bitbucket server git version 2.17.1, CentOS 7x64; can you please give me a hand?

1 answer

1 accepted

1 vote
Answer accepted

HI @datasecmx

The error is with Perl, can you please try to reinstall the Git and see if you can be able to push the commit.

Hi Yogesh re install git in client or Server?

I compiled new git version 2.18.0 and same, unable to commit with same error message.

If you look at the error ..it say cannot locate strict.pm, handle.pm etc file and its related to perl.

We were also face same issue, after reinstalling the Git the issue has been solved.

Here is the same questions related to this but occurred in Bitbucket Data Center.

Hope it helps.

Well I think thats the solution but if I remove perl, system will delete MSSQL, OpenLDAP and other services I have configured before.

Thank you for helping me out.

Worked like a charm, I just ran yum reinstall perl* and its working now.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

Atlassian supported Jenkins integration for Bitbucket Server

We’ve been building a plugin to integrate Bitbucket Server and Jenkins CI, and I’m excited to announce that our alpha is ready to download and install. It lets you seamlessly configure a Jenkins job ...

398 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you