Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bitbucket plugin development :failed to start at 7990 port

Hi Members,

I am developing bitbucket plugin for pre receive hooks . I have plugin sdk and after setup when i run `atlas-run` it gives me below error :

The Tomcat connector configured to listen on port 7990 failed to start. The port may already be in use or the connector may be misconfigured.

 

Since before plugin development I had a bitbucket server already running at 7990 port .I understand bind exception on same port however i have tried stopping service assuming it will create and bind again but it does nothing with endless retry . I tried giving different port in _start-webapp.bat before running atlas-run . Still there was no success .

 

Any suggestion would be highly appreciated .

 

Thank you in advance .

 

1 answer

0 votes

Hi! 

on your laptop some app using the same port, 

please do netstat -anpt |grep 7990 

after you can detect the app

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,884 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you