Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,543
Community Members
 
Community Events
176
Community Groups

Bitbucket pipelines paused even though there is no running pipeline

Edited

I'm running a deployment pipeline on bitbucket with the following steps.

<url_removed>

 

It used to work fine until today. There are no concurrent pipelines running, but the pipeline pauses after saying that another pipeline is in progress. When I click on the pipeline that's blocking the current pipeline, it redirects me to the same pipeline. <url_removed>

I tried rerunning the entire pipeline / rerunning the paused step several times already as the post here https://support.atlassian.com/bitbucket-cloud/docs/deployment-concurrency-control/ suggests.

Is there a way I can manually empty the deployment queue so enable the pipeline to get going again? Or do I need to create another pipeline because this pipeline is dead due to a bug?

2 answers

I'm also experiencing this issue. Already tried until Pipeline #21 because I repeatedly pressing Rerun, I thought it would run the same pipeline but it doesn't and creates new instead. If I click 'another pipeline' link, it's all pointing to the same pipeline #8.

Screen Shot 2022-05-11 at 6.56.55 PM.png

This is the pipeline #8. I put wrong script in the commit, its status is already failed though.

Screen Shot 2022-05-11 at 6.52.17 PM.png

 

This is my first experience using Pipeline, so I also tried to clean up the Pipeline by deleting the log, including deleting this #8 log. Turns out Pipelines cannot be deleted/cleared, now I can't share what the log is.

Screen Shot 2022-05-11 at 7.06.52 PM.png

 

Sorry if me causing this issue 🙏 

It's resolved by Bitbucket development team, thank you! https://bitbucket.status.atlassian.com

0 votes

Hi Tony and welcome to the community.

I believe that you are affected by this incident:

Our development team is working on a fix, you can subscribe for updates via the link on the status page I posted.

If you still experience issues after the incident is resolved, you can reach out to the support team via https://support.atlassian.com/contact/#/, in "What can we help you with?" select "Technical issues and bugs" and then Bitbucket Cloud as product.

Just a heads up, I removed the Pipelines URLs from your post to protect your privacy.

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events