Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,878
Community Members
 
Community Events
176
Community Groups

Bitbucket pipeline successful via ftp but the new file/change was not found in the server hosting

This is my first time using bitbucket pipeline to deploy changes to the server. I've tried a lot of scripts before and the script below seems to be the one that run successfully. But even though in bitbucket it says that the pipeline was successful, I can't find the updated or newly created file in the server hosting. But if the file was updated normally in bitbucket repository source.

Can anyone familiar with bitbucket pipeline help me? I basically want to automate deployment from master branch (when there is a push to master) to a remote server host via FTP. 

Note: as for the FTP credentials, I have tried connecting it via apps like FileZilla and it works perfectly fine. So, the problem was not the FTP credentials


image: wagnerstephan/bitbucket-git-ftp:latest
pipelines:
branches:
master:
- step:
name: Deploy to Production
deployment: production
script:
- git ftp push --user $FTP_USERNAME --passwd $FTP_PASSWORD ftp://$FTP_HOST

1 answer

1 vote
Patrik S Atlassian Team May 24, 2022

Hello @Indra Oei ,

Thank you for reaching out to Atlassian Community! 

Accordingly to the git-ftp documentation , before using the ftp push, you should init the FTP tracking in the remote by executing the git ftp init : 

git ftp init 

You can clone the repository and execute the above command in your local, so all the files will be uploaded to the FTP site. After that, you should be able to normally execute the git ftp push in the pipelines to only synch the changed files.

In case the above does not work, I'd need more verbose logging for the investigation, so could you please update your pipeline to run the push with the -vv flag, like below ?

git ftp push -vv --user $FTP_USERNAME --passwd $FTP_PASSWORD ftp://$FTP_HOST

Once you run it with the verbose flag, please share with us the log output.

Additionally, as an alternative to git ftp you could also make use of the FTP pipe to deploy the files to your remote server, as the example below : 

script:
  - pipe: atlassian/ftp-deploy:0.3.7
    variables:
      USER: '<string>'
      PASSWORD: '<string>'
      SERVER: '<string>'
      REMOTE_PATH: '<string>'

Pipe documentation and examples: https://bitbucket.org/product/features/pipelines/integrations?p=atlassian/ftp-deploy

Hope that helps! Let me know in case you have any questions.

Thank you, @Indra Oei .

Kind regards,

Patrik S

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events