Bitbucket pipeline apt-get update and install Edited

I'm trying to make a build image in my bitbucket pipeline.

In the step I do:

script:
- apt-get update \
&& apt-get install -y --no-install-recommends git curl libmcrypt-dev openssl mysql-client libmagickwand-dev

Which results in a:

Reading state information...

E: Unable to locate package

When I run de build image locally and bash into it and run the exact same commands it works perfectly.

How can I solve this?

 

1 answer

1 accepted

Hi Jorgen,

Remove the forward slash and it will work.

script:
- apt-get update && apt-get install -y

Hi Edwin! Thanks for your reply. I had that before as well, and it didn't work.

But that made me remove \ at the end of the apt-get install command and move the other commands to a separate line.

Now it seems to work, thanks a lot!

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

22,740 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you