Bitbucket not setting up. Permission Denied Error GitLab

Recently I purchased Amazon Linux server. Bitnami Lamp is configured by default. I login on that server using Putty with a .ppk file that server host give to me. After login to server I generating a new SSH key using ssh-keygen. After that I copy key from ~/home/bitnami/.ssh/id_rsa.pub and add that key to my Bitbucket account SSH keys section.
Now when I try to clone my project using SSH method then it gives me error

ssh: /opt/bitnami/common/lib/libcrypto.so.1.0.0: no version information available (required by ssh)
ssh: /opt/bitnami/common/lib/libcrypto.so.1.0.0: no version information available (required by ssh)
Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

But when I clone using HTTPS it works but it keep asking me to providing my Bitbucket password every time I do some action. I don't want to provide my password because other developers also need to pull/push here in that repo. I want SSH method to work perfectly.
So how can I fix this Permission issue for SSH method?

1 answer

This widget could not be displayed.

If you run `ssh -i ~bitnami/.ssh/id_rsa git@bitbucket.org` from that system, does it list the username associated with that key, or mention that the key is an access key for a given repo or set of repos?

Thanks for your fast reply.

when I run above command it gives me following output

PTY allocation request failed on channel 0
logged in as azamalvi.

You can use git or hg to connect to Bitbucket. Shell access is disabled.
Connection to bitbucket.org closed.

 

If you're getting that, then the key is properly installed on the Bitbucket side of things. Is the key listed when you run `ssh-add -L` ?

when i run this coomand `ssh-add -L` i got below error

Could not open a connection to your authentication agent.

After that I run below command

`ssh-agent`

`eval $(ssh-agent)`

and after that I run first command it shows The agent has no identities.
then I run `ssh-add` and then run `ssh-add -L` it now shows me

`ssh-rsa AAAAB3N************************************`

Now I run git clone same error Permission denied (publickey).

I actaully figer it out that it was due to folder issue. And I resolve it by following link (steps)

https://community.bitnami.com/t/correct-folder-and-files-permission/25282/2#post_2

Now after clonig code when I open my project in browser it shows me other fiesl like view folder js folder. So I just want to know is that ok or I need to change some other permissions for that?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

1,524 views 9 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you