Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Bitbucket merge checks not recognizing Bamboo builds from forks


We are running "Bitbucket v8.9.4" and "Bamboo version 8.2.9 build 80215 - 12 May 23"

We have recently tried to configure our Bamboo plans to make use of "Forked repositories are allowed" as described in the documentation. We have tried both manual plans and via bamboo specs: 

      accept-fork: true

The plans are being run in Bamboo, but Bitbucket is not aware of them. I found this mention in the documentation:
The build statuses of PRs from forked repositories won't appear in Bitbucket (...) To see the build results, go directly to Bamboo.

It seems it not only a problem of appearing in UI, but actually getting recognized, as the builds are blocked if settings such as "Required builds" or "Minimum successful builds" are enabled.

Is this a recognized issue? Or "a feature not a bug" kind of thing and we should not expect this to be patched?no_build.png

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events