Bitbucket is not updating git commit through SourceTree, even though remote git has been updated

I've set up my personal git repo into Bitbucket with my existing git, then pushed my local to remote repo through SourceTree. But Bitbucket is not updating new commits that I pushed, even though it has been updated in remote repo. What should have gone wrong?

 

  

1 answer

0 vote

Hi! Could you clarify the description a bit more so we can understand better the issue you're experiencing?

You said you pushed your local repository to your remote repo through SourceTree. Which remote are you referring to? Are you referring to your Bitbucket repo? Do you have your Bitbucket account connected to SourceTree?

You also said that Bitbucket is not updating new commits that you pushed, even though they have been updated in remote repo, to which remote repository are you referring to?

Lastly, are you using Bitbucket Server or Cloud?

Best regards,

Ana

Hi, thanks for your response. 

 

So here's what I did:

1) I have a remote git repo, and cloned to my local

2) I opened Bitbucket account and imported from remote git repo, where the commit history up to that point was showing up correctly

3) I downloaded SourceTree and added my local git repo there

4) I committed/pushed some tests, and commits showed up on remote git repo but BItbucket's commit didn't get updated

5) After reading your comment I've added Bibucket account in SourceTree's Preference/Accounts, changed Bitbucket account as default, committed another test. Still no update.

 

I am using Bitbucket Server. If there is any tutorial to set up sourcetree/bitbucket workflow properly from scratch let me know!

 

Thanks,

 

Nam

Hi Nam, that's weird. You said that you've added your Bibucket account in SourceTree but changes are still not visible in Bitbucket Server: 

  • When you push your changes to Bitbucket using SourceTree, are you getting any errors?
  • Can you try pushing your changes to Bitbucket Server using the terminal instead? Is Bitbucket getting updated? Do you get any error?

For more information, you can also check How to set up SourceTree with Bitbucket Server.

Cheers,

Ana

Hi Ana,

There is no error message in either SourceTree or Terminal. Commits from both sources are updated in my git repo, but no update in my Bitbucket.

And the link you sent me is exactly page I read to set up my Bitbucket. Is there any other info I should look into?

Thanks,

Nam

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

711 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot