Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Bitbucket fatal: Can't access remote

deividuska
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 13, 2019

I tried to set up sftp connection between Bitbucket and Runcloud server. Runcloud only uses sftp connection. Bitbucket config:

image: php:7.3

pipelines:
 branches:
   master:
     - step:
         name: Deploy to production
         deployment: production
         script:
           - apt-get update
           - apt-get -qq install git-ftp
           - git ftp init --user $SFTP_username --passwd $FTP_password sftp://runcloud@1.111.111.11/home/runcloud/webapps/mywebsite/wp-content/themes/mywebsiteTheme

Connection always fails with error fatal: Can't access remote 'sftp://1.111.111.11', exiting...

I tried a different sftp Path combination but the result always the same. sftp://1.111.111.11/home/runcloud/webapps/mywebsite/wp-content/themes/mywebsiteTheme sftp://mywebsite/home/runcloud/webapps/mywebsite/wp-content/themes/mywebsiteTheme

My website Root Path: /home/runcloud/webapps/mywebsite Public Path: /home/runcloud/webapps/mywebsite

Runcload have different as "normal" set up for ftp. For example to conect with FileZila HOST is my server ip. And to get to my website i have to navigate /webapps/mywebsite enter image description here

Not sure what I doing wrong is my sftp path incorrect?

3 answers

1 vote
davo20019
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 4, 2021

I think you should use the --insecure parameter.

 

git ftp init --user $SFTP_username --passwd $FTP_password --insecure sftp://runcloud@1.111.111.11/home/runcloud/webapps/mywebsite/wp-content/themes/mywebsiteTheme
Akula
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 31, 2021

Worked for me +

0 votes
Pascal Bieri September 18, 2022

I have the same problem, nothing seems to work. Did you find the problem?

0 votes
Chirannjevi Panala September 18, 2021

I have the same issue, I tried adding --insecure. still not working

 

image: atlassian/default-image:2
pipelines:
default:
- step:
name: 'Deployment to Staging'
deployment: staging
script:
- apt-get update
- apt-get -qq install git-ftp
- git ftp init --user $SFTP_Username --passwd $SFTP_Password --insecure sftp://111.111.111.111/

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events