Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bitbucket app password login fails


I seem to be having trouble authenticating to my Bitbucket repo using App Passwords.

Here's what I did (following

  1. Enabled 2-factor authentication
  2. Created a test repo with some dummy data
  3. Created an App Password, granted every permission possible
  4. Tried login via git command-line client:
    git clone

Login fails with the following message

Cloning into 'Testrepo0'...
remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.
fatal: Authentication failed for ''

Can anyone point out what's wrong here? Regarding the hint about the account password, I am using the Atlassian account which has a password set. I don't believe it's possible to have it any other way...

FYI: I am, in fact, trying to enable submodules in my Bitbucket Pipelines, which seems to require such hacks to work: Login fails there in exactly the same way.

4 answers

1 accepted

20 votes
Answer accepted

Oh, I'm not supposed to use the name of the App Password as the login user, but rather my own user name. That's unexpected.

Thanks for the hints smile

Sure thing smile

Like Anand Kumar likes this

same issue for me, resolved.

Like # people like this

same issue here. That helped me a lot

Like Anand Kumar likes this

Hi Tarmo,

Even If I use my username and password with https option for git clone, I often face this issue (requires single sign-on and create app password).

Creating app password and using the same with current username instead of the account password, will it resolve the problem?

Thanks in advance,


1 vote

Hi Tarmo,

What value are you using for apppwd_user?



How do we use app password for git commit and push? 

Currently getting follwoing error when trying to commit my changes:

"Because your Atlassian account admin requires single sign-on, you'll need to authenticate with an app password. Create an app password at

fatal: unable to access '': The requested URL returned error: 403"

It depends on where are you trying to accessing from. There are some tools that have specific fields for username and password, other you can inform it in the URL.

I'm not completely sure, but I think it's[your_repo] os something like that.

Anyway, the most important thing to note is that, even after creating your app password, you must use your own bitbucket's "username" with your app's "password". That's the trick

Hi Ronan, 


Thanks for your reply. 

I was able to push my change the way you suggested using following command:

git push [branch name][my repo].git




Like # people like this

Hi Soma,

I'm glad that it helped



I had an similar issue. In the url make sure you are using ur id and the the system will ask for your password. Problem solved

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,888 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you