Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Bitbucket Website And Bash Client Having Severe Network(?) Problems

Michael McQuary August 22, 2023

My git bash client has slowly degraded since the security key issue your company had about 3+ months ago.  Everything worked fine for more than two years prior to this situation.  Doing a simple git push nowadays, I consistently receive things like this (see the last three lines):

Enumerating objects: 47, done.
Counting objects: 100% (47/47), done.
Delta compression using up to 16 threads
Compressing objects: 100% (35/35), done.
Writing objects: 100% (35/35), 7.61 KiB | 2.54 MiB/s, done.
Total 35 (delta 30), reused 0 (delta 0), pack-reused 0
client_loop: send disconnect: Connection reset by peer
send-pack: unexpected disconnect while reading sideband packet
fatal: the remote end hung up unexpectedly

I just now had to do the push six or seven times before it decided to work.

Furthermore, the website rarely wants to work right.  I generally just get the spinning icon with sometimes the header partially loaded, thus not working, and the sidebar sometimes loaded and "working."  Looking in the browser tools nework tab, I see random files (as in not the same files each time) with (pending) that never load.  I have tried the most recent versions of Firefox, Brave, and Chrome.  Firefox literally cannot do anything ever.

In Brave, I deleted my cache and all BitBucket's 18 cookies.  Somehow when I tried to log in again, it knows me still and I don't have to log in.  It takes me to my repositories in the URL, but rarely displays the main content.

I tried Brave on my cellphone, and the site does indeed work with and without my wi-fi hotspot on.

The only thing I can think of, which still makes no sense, is that I created an encryption key using a different protocol than my original one based upon instructions on your site at the time.

Any advice will be appreciated.

---

Edit:  I just received this error message, if it helps:

Something went wrong

Wait a few moments, then try again. If this keeps happening, check the current operational status of Bitbucket Cloud at bitbucket.status.atlassian.com

a504045f8efd4b2ea1777760c7902bbd

If the problem persists, contact Support and include the code displayed above, if one is provided.

---

Edit2:  In Brave, I assigned a specific DNS server instead of the default and *lowered* my Ethernet MTU packet size to 1400 (other sites said to raise it, but that did not appear to work).  Bitbucket is still sluggish, but at least it is usable.

If you have any other advice, I would still like to hear it.

 

1 answer

1 accepted

0 votes
Answer accepted
Patrik S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
August 24, 2023

Hello @Michael McQuary and welcome to the Community!

Since per your description, the slowness also affects the navigation in the UI, it's likely not related to the SSH key rotation that happened a few months ago, as those are different protocols.

From the symptoms of the issue you are describing, it seems like a network issue in the path between your ISP and Bitbucket Cloud infrastructure. When connecting to Bitbucket, the packages can take multiple routes and hops to reach Atlassian servers, and most of the routers in between are outside of Bitbucket immediate control.

With that in mind, I would suggest following the troubleshooting steps contained in the below article to help identify where the issue is located :

This article also provides a workaround that you can use temporarily, which is to modify your operating system's hosts file to direct traffic to Bitbucket's legacy IP addresses - which are not anycast to the internet. In some situations, this might help improve your connection, as it bypasses the AWS Global Accelerator from the default anycast IP.

Hope that helps! Let me know in case you have any questions.

Thank you, @Michael McQuary !

Patrik S

Michael McQuary September 18, 2023

While using the legacy IPs worked, I found the true problem appears to be my ISP.  If I VPN to NYC, everything works lightning fast (including other websites that seem to use "Edge" servers that were hanging a lot).  I even VPN-tested LA (other side of the country) and still everything was very fast.  I'm blaming my ISP.

Thanks though for all your information!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events