Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,149
Community Members
 
Community Events
176
Community Groups

Bitbucket Runners - Self hosted - 403 errors

We have suddenly started receiving these errors on our self-hosted runners:

 

Response Summary: HttpResponseSummary{httpStatusCode=403, httpStatusMessage=Forbidden, bodyAsString={"error":{"message":"Forbidden","detail":"Could not find runner associated with oauth client.","data":{"key":"rest-service.rest-service.forbidden","arguments":{}}}}}

 

The error is very random, happens on different projects. There have been no changes to our pipeline.yml files or permissions in our BB instance.

 

I've upgraded all of our runners to the latest version but still seeing the issue.

 

Any ideas?

3 answers

1 accepted

0 votes
Answer accepted

I understand this is now fixed on the Bitbucket side.

I've just killed all previsious images and containers, run with 

Runner version:
current: 1.342
latest: 1.342

and it's alive  

Great! Did the same. Works! Thank you! Looks like they have just updated worker images

I did try this earlier without much success...

What versions do you have ?

same, 1.342. It's working now after BB fixed it on their side.

Hello! Can just approve. We have 2 runners on our kubernetes platform and both of them receive such errors

When did you start receiving the 403s?

I noticed that about an hour ago. But there were no builds before

Same - 3pm UTC.

And our runners are updated to the latest version

Now my builds are stuck in Queued state. No error but also they are not assigned to runner. Looks like there is some global problem in bb pipelines.

I've tried to raise a separate ticket with BB

Like Grigory Kazachenkov likes this

Received a response, they're aware of the issue and are looking to fix.

Like Grigory Kazachenkov likes this

We are also seeing this issue.

Like Grigory Kazachenkov likes this

We are also seeing this issue.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events