Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,286
Community Members
 
Community Events
176
Community Groups

Bitbucket Repository doesn't exist or don't have access

I have had a project set up in bitbucket for roughly 4 years.  I have been able to push / pull without issue.   I missed the March 1st 2022 deadline to switch over to app passwords, but was recently able to push code up mid March.    I have been trying to update to use the new app passwords.   I had created the password and tried the following

git remote set-url origin https://<bitbucketUsername>:<appPassword>@bitbucket.org/<repositoryName>.git

Upon doing that and attempting to push up a branch, I have been getting 

The requested repository either does not exist or you do not have access.  If you believe the repository exists and you have access, make sure your authenticated.

Is there another command that is required to be run to allow me to push branches up?  I tried creating numerous app passwords with various permissions, but none have been successful

1 answer

0 votes
Caroline R Atlassian Team Apr 05, 2022

Hi, @JohnSaundersIII, welcome to the community! 

By the error message you are receiving, these are some of the things that can be happening:

By the error message you are receiving, this problem seems to be associated with one of the following reasons:

  • Your account doesn’t have access to this specific repository, or you might have informed the wrong workspace/repository name;

  • The App password you are using doesn’t have the necessary permissions. I recommend that you create a new one and select all the options when creating it and try it again;

  • Make sure you are using your Bitbucket username. You can confirm your username by accessing your personal settings: https://bitbucket.org/account/settings

Please let me know how it goes and feel free to share any additional questions regarding this case.

Kind regards,
Caroline

Hi, Iam also facing same issue 
Tried creating new app password with all boxes checked in- still the same as mentioned by @JohnSaundersIII 
Help would be appreciated

Thanks
Ravi

Like tore likes this

Issue resolved for me. It has something to do with my access to that repository 

 

Thanks,

Ravi

How did you solve getting access to that particular repository?

I was able to fix this by creating a new ssh key. But the pin didn't work. I created another ssh key and placed it in a new directory. I am able to commit now. 

Chris Obi I'm New Here Aug 25, 2022

C:\Users\dell\Desktop\git-test1>git remote add origin

https://christokras@bitbucket.org/christokras/chris-git-test.git
error: remote origin already exists.

C:\Users\dell\Desktop\git-test1>git push -u origin master


remote: The requested repository either does not exist or you do not have access. If you believe this repository exists and you have access, make sure you're authenticated.


fatal: repository 'https://bitbucket.org/christokras/workspace/repositories/' not found

 

can somebody help me on how to resolve this issue. I have been stuck here all day. I need help please

Hi Chris,

The output of the git push command shows that the remote url of the repo is not valid. It looks that this url is set to 'https://bitbucket.org/christokras/workspace/repositories/' which is not a valid repo url.

The output of the command git remote add origin indicates that a remote named origin already exists. In order to change the remote url of origin, you will need to use the following command instead

git remote set-url origin https://christokras@bitbucket.org/christokras/chris-git-test.git

In case you still face issues, please create a new question via https://community.atlassian.com/t5/forums/postpage/board-id/bitbucket-questions and we can look into it (it can become convoluted to troubleshoot multiple users' issues in one question, so it's best to have a separate question).

Kind regards,
Theodora

Hi Theodora, I have tried this solution 

git remote set-url origin https://christokras@bitbucket.org/christokras/chris-git-test.git

which does work but then prompts for a password when i want to push to the branch, i have created an APP PASSWORD and tried using that as well but to no avail.

i get this error

remote: Bitbucket Cloud recently stopped supporting account passwords for Git authentication.
remote: See our Community post for more details: https://atlassian.community/t5/x/x/ba-p/1948231
remote: App passwords are recommended for most use cases and can be created in your Personal settings:
remote: https://bitbucket.org/account/settings/app-passwords/
fatal: Authentication failed for 'https://bitbucket.org/---/repo.git/'

Hi.

I have the same error message when I try to get repository data: https://api.bitbucket.org/2.0/repositories/{username}/{repository}/src

"The requested repository either does not exist or you do not have access. If you believe this repository exists and you have access, make sure you're authenticated."

I can get user info from: https://api.bitbucket.org/2.0/repositories/{username} so I know that I'm authenticated.

 

I see that possible solution is to add ssh key.

I've added ssh key to my personal settings.

Question is, how can I use it in my API calls.

 

If this is not the right way, how can I get repository files using API

 

Edit: seams that it was because repository was marked as private.

Question is, how can I apply https://api.bitbucket.org/2.0/repositories/{username}/{repository}/src to private repository? I'am an owner and my token has all available permissions in scopes.

Like Marcin likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events