Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bitbucket Pipelines "command not found"

Pipelines is suddenly failing, even with configurations that used to work. I've tried several images, different commands but they all result in the same.

I've reduced my configuration to rule out any other issues to the following:

image: php:7.2-cli

pipelines:
  default:
    - step:
        script:
          - php -v

 

Which results in:

php -v
bash: php: command not found

It throws the same error on commands like "ls" or "which".

What's going on?

1 answer

1 accepted

2 votes
Answer accepted

Just as I posted this it struck me that I added a "PATH" env variable..., whoops!

Phew, took me hours to get to this answer

Thanks a lot!

Like Diego Dominguez Alvarez likes this

I could not understand the answer guys :/

Like Tharinda likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,717 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you