Bitbucket Git Submodules with SSH Keys and valid permissions are NOT cloning

Bartosz Solowiej December 15, 2017

I have a valid ssh-key copied into my Bitbucket user settings. I can clone any top-level repo that I have access to.

I can also validate that my works by running:

ssh -vT
Authenticated to ([]:22).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: pledge: network
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
logged in as **REDACTED**.

BUT when I clone a top-level repo with submodules and run:

git submodule update --init --recursive"

# I see many "Permission denied (publickey") messages to repos I also have permission to

Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I can clone my submodules over ssh individually, NO PROBLEM. Just when the top level repo attempts to update all the submodules, it fails. 

What is going on?

(((  I do not want to use https for submodules. )))


2 answers

1 vote
Pelle van der Heide July 19, 2021

Found this too, make sure you connect to the submodule repo with the right user (

When no username is given ssh uses the current user, who has no permissions on

0 votes
Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
December 29, 2017

Hi Bartosz! Are you still experiencing this issue? If you are, please give us more info so we can continue helping you:

- Are you using Bitbucket Server or Cloud?

- Where are you cloning the repositories from? Where are you cloning them to?

Best regards,


Deleted user March 7, 2018

I'm not the reporter but I have this issue. I'm using bitbucket cloud and cloning repositories to the my local e: drive. 

git version

cmd line: git clone --recurse-submodules

Deleted user March 7, 2018

Solved it, if anyone else comes looking make sure your ssh key does not have a passphrase.

Like Alexander_007 likes this
Paul Russell October 14, 2019

Surely having a passphrase on an ssh key is considered best practice. 

I don't think this is the genuine root cause of this issue. 

Pushpender April 6, 2020

I am also facing the same issue and I do not have any passphrase for my ssh key. 

Nicolas Pascual April 18, 2022

Same issue here. Both repositories are mine, both with SSH key (the same), both can be cloned without any issue. 

I'm getting the same error while trying to clone the submodule. 

Like likes this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events