Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bitbucket Export pull requests

Deleted user Aug 29, 2016

We are required by QA to prove that we approved all of our pullrequests and export such a list to an external audit company. Is there a way to export the list of all pullrequest to excel or a different file format?

I had a look at the Bitbucket API but it seems that this will not do the deal. Maybe this is an Issue for JIRA as well, as the required data is collected on the release summary page?

5 answers

Any update on this? We also need something to export the pull requests for our Management level that do not have access to Bitbucket.

Hello Folks, Is it possible to export a report of all the Pull requests merged in Bitbucket cloud for a given time period ?

0 votes
Deleted user Jun 01, 2017

Got the task done by using the REST-API of bitbucket and wrote a small perl-script to export all the fields we found. 

This did not take much time and the script is only about 80 lines of code, so I would recommend doing this.

I just added Bitbucket support to Export Pull Requests. It'll export them to a CSV. Check it out: https://github.com/sshaw/export-pull-requests

hi, I've tried your plugin and it looks good, but, the User column remains blank...  

Hi, this was fixed in v0.3.4. What version you using?

hi 

I'm using v0.3.3 (GitHub v0.19.0, GitLab v4.17.0, Bitbucket v0.1.7)

Hi! We do use Bitbucket server (formerly Stash) v5.1.3 and we also need to export all pull-requests details (pull request id, reviewers, etc.) done from a certain date (since 01/11/2017 till today) on certain repositories.

If I get it right, repository attached by @sshaw is meant for Bitbucket cloud (uses rest api 2.0), while in our case we only have rest api 1.0 so it doesn't work.

At this moment I am considering implementing a custom application/script that does all this logic (iterate through all pull-request pages, filter dates, etc.).

Before start doing so (it will take a while to implement), I was just wondering if any of you knows about an alternative that could save me quite some time (e.g. a github repository I could use as a basis, a Bitbucket server out of the box feature, a Bitbucket plugin, etc.) .

Thanks in advance.

@Josep Serra, what makes you think the Bitbucket client works with 2.0 only? Codebase does reference `1.0` in API paths... 

Thanks @sshaw for the quick reply! Mmm it sounds weird to me since I run the latest version and path generated was referencing api 2.0. Consequently it threw a 404 exception since the path could not be found in our Bitbucket server (If I manually modify the path to api 1.0 then it worked). At that point I assumed it was thought for api 2.0. Maybe I did something wrong. I have finally implemented a custom script to solve my issue. thanks anyway for the support 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

2,575 views 1 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you