Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,393
Community Members
 
Community Events
176
Community Groups

Bitbucket Cloud recently stopped supporting account passwords for Git authentication?

Why am i getting this problem? Is there any solutions.

 

Kindly help this.

5 answers

1 accepted

16 votes
Answer accepted
Charlie Misonne Community Leader Mar 09, 2022

Hi @DeepakS ,

That's correct. Atlassian started disabling this on 1 March.


Instead of using your own Atlassian account password you should use an app password. This can be done on this page: https://bitbucket.org/account/settings/app-passwords/

Read more about the deprecation notice here.

This is very odd. I am trying to get list of commits from repository by hitting this url:

where i send username:password where username is my account email and password is the key i have created in App Password. Yet i do get 'Bitbucket Cloud recently stopped supporting account passwords for API authentication.' Any ideas?
Like # people like this

This also failed for me when I was using my account email. However when I used my username instead of my account email the login process worked. You can see your username under Personal settings -> Account settings.

Like # people like this

Works like a charm, thanks @Kasper Schlein-Andersen 

Like Felipe Pereira likes this

Not for me. I have my username rather than email address in the credentials for my account in Sourcetree, as well as the new app password I just created, but am still getting the error. Suggestions appreciated.

Like Sergey Mokhov likes this
Like # people like this

Hi @Charlie Misonne your method worked! thanks a lot.

Like Felipe Pereira likes this

BitBucket has moved from Account Password to App Password from March 1, 2022,  You need to create and use App password going forward to perform Git Operations.

 

Checkout the detailed article on Bitbucket Cloud recently stopped supporting account passwords for Git authentication

thanks @John Rix !!

https://community.atlassian.com/t5/Sourcetree-articles/Bug-Fix-Sourcetree-for-Windows-authentication-error-when/ba-p/1965968


My issue resolved at the last step when I deleted passwd file.. I was thinking that I might need to reinstall Sourcetree but I got saved..

Thanks again!

Like Lázók Jácint likes this

Nice!!!  saved my ass   xD

Amazing, worked like a charm!

For me it works one day and stops working another day. I have to keep revoking and creating new app passwords...

0 votes
Karthick S Atlassian Team Apr 01, 2022

Hello @DeepakS

Welcome to the community!

As per the Bitbucket communication, Atlassian account passwords are deprecated for Bitbucket API calls and HTTPS git activity (clone, push, pull and fetch), and are being replaced by App Passwords.

App passwords are meant to substitute your real account password and are designed to be used for a specific purpose and limited permissions. They can be easily created and revoked when needed.

If you want to check more information about the App Password, you can reference this documentation.

Please note, that you need to enter the username, not the email ID. You can get the username from your personal settings

I hope this helps.

Regards,
Karthick S

When you enter the app password its working fine but when i am trying to enter the password then i am getting the below error .

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events