Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,654
Community Members
 
Community Events
176
Community Groups

Bitbucket: Authentication failed - since March 1st 2022

Edited

Good afternoon,

Yesterday I received a Bitbucket mail explaining:

Beginning March 1, 2022, you will no longer be able to use your Atlassian account password when using Basic authentication with the Bitbucket Cloud REST API or Git over HTTPS.

I've a Bitbucket account with some personal projects.

And I use GitHub Desktop to work with all GIT stuff. I love it.


Those personal projects sync with no problems through GitHub Desktop to Bitbucket, with my main user/pwd as always did.

But I've some "shared" projects, where I as a contributor (admin privilege), when I try to sync, they don't. Authentication failed error appears, asking for some new credentials.

I've created App Passwords with EVERYTHING checked on my account. The token is useful for syncing my projects, but fails the same with shared ones.

As those shared sync failing projects were local enterprise developed by 2 users, and those 2 do not work here anymore, I've updated their Atlassian account passwords of them and created App Passwords with FULL privileges to test if with their credentials or with their app tokens would login pass. But fails. There is no way to sync anymore those shared projects (no pull, no push, no refresh... nothing).

I've deleted ALL windows keychain saved credentials, to recreate them. No way. My projects asks first time for user/pwd and everything starts to run smoothly, and shared ones, keep failing and asking credentials.

And that's rare too! Because my ones, keep working with my Atlassian user/pwd pair which suposedly souldn't since today!

 


I've just wrote this post on Isuees list to GitHub Desktop:

https://github.com/desktop/desktop/issues/14035

 

They closed it saying; not a problem from us.

 

Sumarizing:

 

  • I've a BitBucket account with some personal projects created by me. Those sync on my PC and correctly managed from GitHub Desktop. They sync OK today with my BitBucket account user/pwd pair.
  • But I've some sync projects on same PC where I'am a contributor (not my projects, but other fellows ones), but I've ADMIN rights on those projects.
  • Those are the ones that do not sync. If I refresh, it gives me an Authentication Failed and no user/pwd possible works. I've created an APP Pwd for all user accounts, with all permision checks marked. Full rights. Used those tokens to login and nothing.
  • My app password works on my projects as my Atlassian user/pwd pair do. But shared projects simply do not sync. Keep asking for credentials.

 

Any ideas?
Anyone?

 

Thanks.

 

2 answers

1 accepted

1 vote
Answer accepted

Ok! Solved!

Basically:

- Completly close Github Desktop and developing GUI. Everything releated.
- Delete all bitbucket related credentials from Windows "keychain".
- Delete entire shared projects folders from my local (not mine projects, only shared ones). Or save on to diferent paths away, if you need to recuperate some made code changes. But be sure the folders are not were they used to be anymore.
- Open Github desktop and travel to shared projects. It says they're removed and asks for removing from Github Desktop. Accept removing all of'em.
- On to Github Desktop, go to one of your own projects and re-sync (fetch button). It's going to ask for credentials. Write your Atlassian USER, the one appearing on bitbucket personal page. NOT the mail, but the user AS-IS. You need to have an APP Password created with ALL permisions set. All the checks you can check, do it. Save the token received on App password creation, and use it on GitHub Desktop login prompt.
- It normally syncs and everything works as expected. So now, it's shared projects turn.
- Forget GitHub desktop. Open CMD an do a CLONE of those removed project, with the APP password and atlassian user on it, like this: `C:\Users\*******\AppData\Local\GitHubDesktop\app-2.9.10\resources\app\git\cmd\git.exe clone -b develop https://ATLASSIANUSER:APPPASSWORD@bitbucket.org/*******/*******.git C:\PATH\TO\FOLDER\WHERE\REMOVED`
- Everything is going to get on place. And then, back to GitHub Desktop, you need to manually add the project through ADD button and selecting "Add existing repository". Choose your recent cloned path and voilà!
- You're free to sync, push, pull or whatever is needed.

Drastic solution, but functional one.

Now I have to resolve piplines to AWS, which are failing on the last part of the deployment with a:
`INFO: Deployment created with id xxx.
INFO: Waiting for deployment to complete.
aws deploy wait deployment-successful --deployment-id xxx
Waiter DeploymentSuccessful failed: Waiter encountered a terminal failure state
ERROR: Deployment failed. Fetching deployment information...
...
"errorInformation": {
"message": "The overall deployment failed because too many individual instances failed deployment, too few healthy instances are available for deployment, or some instances in your deployment group are experiencing problems.",
"code": "HEALTH_CONSTRAINTS"
}, `
don't even know why...

Thanks!

Ok! About pipelines, solved too.
Found the error on Bitbucket CI/CD pipelines. Releated with instance health.
Found the error on google. Ask to look at AWD console on CodeDeploy movements and search fo the details on errors there appearing.
All google searches say: look at the service on the AWS instance running. Be sure its ready and running.
It is. They say: look at the logs! I do and found something releated with ssl, ruby, permisions, yada yada...
Search the error and a guy says: I usually solve this simply restarting the CodeDeploy service on the instance.
Said and done. All works back to normal now.

So for me, all done. Struggling travel, happy end.

0 votes
Patrik S Atlassian Team Mar 02, 2022

Hello @Marc Reig ,

Thank you for reaching out to Atlassian Community.

From the details you have provided so far, it seems the issue is related with missing permissions on the repository you are trying to access.

In order for us to check the internal tools and figure that out, would you please share the workspace/repository names masked (with asterisk in some of the letters), of the repositories you are having authentication issues while cloning ?

Also, have you tried to clone the repository using git command line directly, like the below example, and faced the same behavior ?

git clone https://USERNAME:APP_PASSWORD@bitbucket.org/WORKSPACE/REPOSITORY.git

 Do let us know if you have any questions. Looking forward to hearing from you!

Thanks, @Marc Reig .

Kind regards,

Patrik S

I have exactly the same problem since yesterday also and haven't found a solution yet.

Like # people like this

Morning @Patrik S!

Sorry for the delay, I'm on Spain and it's 10am now! Coffee time.

 

Ok, I've tried to sync my projects through Github Desktop now, and it doesn't work. I had to use my full permisions APP password and it started to work normally again.

Seeing this, I thought that mybe the shared repos sync problem would be gone, but no.

I've tried my user with APP paswword. Owner shared project user/pwd and app pwd. Nothing.

Other contributor users credentials pair and app passwords. Nothing. Still not working.

 

The clone from cmd directly from a shared project, works with no problem.

I can reclone as many times I want to separate folders to test, with my Atlassian credentials (and app password). 

Nothing more.

 

Is there a way Patrik to send you this data you've asked on a more private way?

 

Thanks!

we have exact same issue in our case GitHub importer stooped working from GitHub web and even with application password, it simply does not work and gives me authentication screen again and again

Patrik S Atlassian Team Mar 16, 2022

Hey @Rati Dzidziguri ,

I would like to ask if you could please create a new question for your issue, providing details on the errors you see.

We generally encourage users to create a new question for their issue instead of posting on someone else’s question, because

1) the root cause and resolution may be different for each case

2) a question can become cluttered and difficult to follow if we try to troubleshoot multiple users’ issues in it.

Please feel free to let me know if you have any questions.

Thanks, @Rati Dzidziguri .

Kind regards,

Patrik S

This is soooo frustrating - same issue today - yesterday, there were no issues - I spent hours fixing this last week.  Its a continual battle working with bitbucket/atlassian authentication issues. Its affected a few people on our team and wasted so much time.

Like # people like this

still facing the same issue. Someone kindly help

Thanks

Same problem here. Same bash scripts worked for many years, and now they don't. Please do something.

Patrik S Atlassian Team Apr 12, 2022

Hello everyone,

It seems the issue you are facing is due to the recent account password deprecation that happened on March 1st 2022, and you should use your bitbucket username(not e-mail address) and an AppPassword for authenticating to git over HTTPs and calls to Bitbucket API.

For more details on how to resolve this issue, please refer to our community post here:
https://community.atlassian.com/t5/Bitbucket-articles/Announcement-Bitbucket-Cloud-account-password-usage-for-Git-over/ba-p/1948231
this post provides detailed instructions users need to take to help resolve the issue. This community post also provides answers to FAQ, make sure you scroll to the bottom of the page to find the answers.

If after reading the community post you are still facing issues, my suggestion would be that you create a separate question for your issue, providing details on the errors you see so we can better investigate your particular case.


Thank you!

Kind regards,

Patrik S

Like Michael Haslecker likes this

I created an app password since the change. Everything has been working for about a month and from today I am stuck again I cannot push to the repository...

I tried revoking the app password and creating a new one but it doesnt do the trick.

 

 

Edit: problem fixed, it was my fault. I renamed the repository in bitbucket.

GitHub Desktop doesnt say what the problem is, it just show the authentication window.

When using the Git command I was able to figure out the error.

Like Kamil Papp likes this

going back to github. that just works

Like looknear likes this

Username with app password works for me.

Like Valentina likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events