Bamboo did not sync changes before building

I have Bamboo setup now to build our entire source tree. (Daily Build). I made a change to a file on my Dev machine, and checked it in. I then went to the build server and kicked off a build.

Under the "Code Changes" section it shows the checkin, however the file I changed DID NOT get updated. I have no explanation for this, but it worries me. I've tried to force a build several times since then and it does not update that file.

We use Subversion to store our code.

Has anybody seen this? Is there a setting somewhere I need to change? I'm a little worried about this, if we can't count on Bamboo to sync our tree properly.

Thanks,

Jim

1 answer

1 accepted

This widget could not be displayed.

I think I made a mistake. I had also disabled one task and enabled another. I didn't realize that it used a separate build-tree for that. I was looking in the disabled build's tree, which wasn't being updated.

I think Bamboo was working correctly. (whew).

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 10, 2018 in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

249 views 14 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you