Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,372
Community Members
 
Community Events
176
Community Groups

BFG repo cleaner in remote on free account

Hi, 

I cleaned my repo with the instructions from

https://rtyley.github.io/bfg-repo-cleaner/

and pushed to remote but the repos size increased

I can see that the repo size is significantly smaller locally

Should the gc be run in remote also ? How to do this ?

-Jani

1 answer

1 accepted

0 votes
Answer accepted

Hi Jani,

I'm afraid that users cannot trigger a git gc on remote repos at the moment.

We have a feature request about this in our issue tracker:

I can trigger a git gc for your remote repo. Could you please let me know what is the remote repo's size now (from Repository settings > Repository details > look at the field Size), so I can identify it and run a git gc? (I'm asking because I see your own several repos)

Kind regards,
Theodora

thanks, the size is 1.54 GB

Hi Jani,

You are very welcome.

I ran a git gc for that repo, its size is 786.3 MB now.

Does this agree with your local repo if you run git count-objects -Hv ?

Kind regards,
Theodora

hmm.. maybe I don't understand how this works but my local mirror clone repo looks like this:

ruohomaa@LAPTOP-5DOSVT93:~/codes/salesforce-compare.git$ git count-objects -Hv
count: 0
size: 0 bytes
in-pack: 14317
packs: 1
size-pack: 20.14 MiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes

I followed the instructions here: https://rtyley.github.io/bfg-repo-cleaner/

Now the remote size is 804.11 MB. I cleaned some more. Could you run the gc again

if I run the git count-objects -Hv in salesforce-compare repo I cloned (after you ran the gc) from remote it gives this:

ruohomaa@LAPTOP-5DOSVT93:~/codes/salesforce-compare$ git count-objects -Hv
count: 0
size: 0 bytes
in-pack: 14357
packs: 1
size-pack: 20.72 MiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes

I was trying to setup the source code mirroring with google "Cloud Source Repositories" and the sync resulted in an error.

Apparently others had this same problem with >700mb repositories

but it seems to work now even if the size says > 800mb on "Repository Details" page

Could you do the gc still once more because I cleaned a bit more

Norbert C Atlassian Team Feb 21, 2022

Hi @ruohomaa 

Let me step in as Theodora is out of office this week. I would like to inform you that I ran another GC on your repository and the size has reduced to 20.9 MB.

Please let us know if there's anything else we can help you with?

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

Sorry for the late reply, this seems to work now

Norbert C Atlassian Team Mar 28, 2022

You're welcome @ruohomaa  I'm glad to hear I was able to help :) 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events