Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,769
Community Members
 
Community Events
176
Community Groups

Azure DevOps CI (push) triggers not working

A few days ago, my Pipeline CI push triggers stopped working in Azure DevOps. I've recreated the webhooks in Bitbucket (noticed the change in API version to 7.1) but still doesn't work.

3 answers

Seems like CI is working again. Check it.

Ours is working again now.

Ours seems to be as well. Cheers

Ours seems to be working now too

Same here. Last Wednesday (9th Feb) was the last time I saw an automatic build in devops.

Same here, also stopped on the 9th of Feb 

Like # people like this

We are having the same issue, anybody got any ideas on how to fix this?

Like milos_cancarevic likes this

If none of us have changed anything, but all our pipelines stopped at the same time, sounds like something has changed either in devops or bitbucket, don't know which one though.

I raised an issue with devops services support on Monday, not heard anything back yet.

Like milos_cancarevic likes this

We are having the same issue. It started happening on 9th Feb. 

The pipelines respond to the creation/update of a Pull Request but not the merge of the Pull Request.

The bitbucket webhooks ( that were automatically added by azure devops during the pipeline creation ) appear to be called successfully ( there is a 200 status returned by azure ), however the pipeline is only triggered automatically when a PR is created/updated and not when it is merged.

---

https://support.atlassian.com/bitbucket-cloud/docs/troubleshoot-webhooks/

We are having the same issue. It appears to have started around the 9th of Feb.

Like milos_cancarevic likes this

we are facing the same issue only few builds are getting triggered 

Same issue here.
Tried copying the Webhook payload and manually triggering the pipeline using the payload - still no dice.
Something has definitely changed.

Like Alex Billson likes this

Having the same issue in our environment, have tried the resolution steps mentioned in this post and I've seen it work once at most. Having to resort to manually kicking off the builds for the time being

I’ve just got my environment to work, I took these steps:

 

  1. Select Pipelines from the left menu
  2. On the Pipelines page, click the 3 dots on the right and select “Manage security”
  3. At the bottom left under Users is the Build Service user, I selected this and then changed the “Queue builds” option from “Not set” to “Allow”.
  4. One pipeline seem to work straight away another I had to save it a couple of times but it then started to work.

 

Hope this works for you.

It didn't work for me, unfortunately.

It is actually really temperamental for me now, sometimes it runs and sometimes it doesn't.  It is such a pain in the butt. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events