Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,856
Community Members
 
Community Events
176
Community Groups

Authentication fails when pushing docker image to private repository

We have a pipeline setup in Bitbucket that builds multiple docker images and pushes them to a private repository. Suddenly we are getting a "error parsing HTTP 403 response body" error when the "docker push" command is being run.

We are calling "docker login <url to private repository> --username <username> --password <password>" before doing the push, and that call returns "Login Succeeded".

While checking on the receving end, the Authorization-header doesn't seem to be valid, it's far too short.

The last time the pipeline worked as it should was in February, the 18th. We haven't done any changes to the pipeline after that date.

1 answer

0 votes
Patrik S Atlassian Team Mar 16, 2022

Hey @Jan-Erik Stensli ,

Welcome to Atlassian Community!

I understand you are currently facing issues to push docker images to your private registry using Bitbucket Pipelines. As per the details you have provided, you mentioned nothing has changed in the pipeline since your last successful run, so I would like to ask you the following :

- Could you try to docker login with the same username and password in your local machine, and try pushing the image to your private repository and see if that works ?

- Would you try changing your pipeline to login and push to dockerhub instead, and see if you face the same authentication error ?

With the information above we'll be able to proceed with the investigation.

Thank you, @Jan-Erik Stensli 

Kind regards,

Patrik S

@Patrik S Thank you for your response. I've tried to push to dockerhub, and that works. I have not yet been able to test pushing to our private repository from my local environment, since that repository only allows certain IP:s to push. I will reach out to the persons in charge of that repository and ask them to give me access. It's probably something in the setup on their end.

Best regards,

Jan-Erik

Like Patrik S likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events