Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Authentication fails for existing local repositories


Following the authentication method change from March 1st, I added a SSH Key to my account and added that key in Pageant.

I can clone a repo and push/pull, but for an already cloned repo, I cannot.

I have a few repos cloned locally and I cannot use them anymore.

I started cloning them again, but it takes time...

What needs to be done for the old repo to take the authentication changes?

I use TortoiseGit on Windows.


2 answers

Thanks, I ended up checking out the repos again.

0 votes

Hi @messier79,

If the existing repos are using HTTPS, you will need to change the remote URL for each of these local repositories from HTTPS to SSH.

I'm not very familiar with TortoiseGit, but somewhere in the repo's settings there should be a configuration option for Remote.

If the URL displayed there is an HTTPS one:

you should change it to the following, in order to use SSH:

This is something you can also do from a command-line application.

Navigate to the directory of each repo, and run

git remote -v

If you see in the output

origin (fetch)
origin (push)

You can run the following command to change the URL of the remote to an SSH one:

git remote set-url origin

Kind regards,

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events