Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Atlassian vscode question: When selecting "Start Work" on an issue. Source branch is not populated.

This is a question about the Atlassian vscode plugin.

When I start work, I see that the Repository field is set correctly, but "Source Branch" is empty with "No branches found", Clicking the drop-down displays "None".

What am I missing setup wise?

13 answers

Not sure.  But mine was working and it has started not working.  Not sure it is because the most recent update which I recently applied.

+1 here - I also had it working and now it mysteriously isn't, and I'm not aware of having changed anything

Like # people like this

Same here. It was working on March 1st, but appears to no longer be working for me.

Same problem. Was working fine last week.

Same problem. "no branches found"

Same problem. :(

Same problem here. smh

The issue is occurring in VSCode version 1.76. I downgraded to version 1.75.1 and the problem does not occur.

If you also want to dowgrade:
1) first disable automatic update in settings (Ctrl + , or Cmd + ,) look for Update:Mode and change it to manual.
2) Download version 1.75.1 from the official website appropriate for your environment:
3) Install VSCode 1.75.1.


Hopefully the issue will be resolved in version 1.77...

Like # people like this

@Marco Guinter Alberton downgrading works for me. Thanks

Like Marco Guinter Alberton likes this

It's strange since Atlassian extension 3.0.2 has been out for weeks (and was working fine until a few days ago), but I tried rolling back to 3.0.1 anyway -- and that still couldn't find source branches.

I tried updating git, (from 2.25.0 to 2.39.2) just in case that was affecting it -- nope.

But the regular git support in VS Code can find the source branches just fine.

Like Marco Guinter Alberton likes this

Same here. Did not work since last week. Downgraded according to the suggestion of @Marco Guinter Alberton and it now works fine. Thanks.

Hope it gets resolved in a later update.

Like Marco Guinter Alberton likes this

Same this occurred to me. Thanks for your suggestion @Marco Guinter Alberton, it worked.

Like Marco Guinter Alberton likes this

Strangely enough, even when I set my update mode to manual in VSCode, it still updates automatically and I get to downgrade it more or less every day. It really is getting annoying.

Also impacted and wasted an hour on it this morning thinking I had done something, hope they can resolve soon.

I saw a pull request for this today.  Not sure where this gets rolled to the VSCode Marketplace

It's merged and tagged 3.0.3 so I'd expect it to show up in the marketplace fairly soon...?

Version 3.0.3 is now available and I just confirmed that it works as before.

Like # people like this

Sam, is Create Pull Request working for you now?

I get:

Error creating pull request

Cannot read properties of undefined (reading 'site')

With VS Code 1.77 and Atlascode v3.0.3.

I can Start Work to create the Branch from a Jira ticket now, but still can't Create Pull Requests like I could before.

Perhaps stranger still: I can create pull requests using the extension in one workspace but not in the other.

The non-working workspace / repo was working fine before this whole debacle.

I can do "start work" in both and create branches.

Any ideas for debugging this out somehow resetting the workspace / repo setup?

Like yakirgb likes this

Had the same issue , V1.77.2 resolved this and working fine now

The tracking issue for it should be here:

But it seems the issues on the repo have been made private a few days ago when a bot started heavily spamming it. Last I saw there was no response from Atlassian.

As others have said this started in VS Code 1.76 so a workaround is to downgrade to 1.75.1, unfortunately there are big fixes/features in 1.76 that I would prefer not to downgrade.

I agree with the not downgrading.  Hopefully, they resolve soon.  This feature made working with Jira much easier.

Thanks for the link, unfortunate it's been made private. I also don't wish to downgrade VsCode as I use it with other projects that don't need to deal with JIRA. Guess we wait.

FYI I've setup an alert for any new commits or PRs on the repo:

If anyone has a commercial relationship with Atlassian it would be great if you could file a ticket and let us know the status.

I've asked my IT department, I'll let you know if we make any progress.

Like # people like this

Released now as 3.0.3!


You will need VS Code 1.77 or higher.

Like # people like this

Thank you! It works correctly. What a relief finally!

Confirmed! Thank you so so much for giving me my workflow back!! 🎉

Version 3.0.3 is now available (just release) and I just confirmed that it works as before.

I've now updated to VSCode version 1.77.3 and Jira and Bitbucket (Atlassian Labs) version 1445536 and it's resolved, working fine now as expected.

This revision is large and many issues have been resolved, but I couldn't find a specific comment about it in the release notes as well as on GitHub.

The important thing is that it was resolved. Enjoy!

Looks like the issue was fixed. Works fine for me now!
Thank you!


P.S. I didn't update anything or downgrade previously

Yup still having this issue, on VS Code 1.76.2

Azure DevOps services works as expected.

Same issue here. Still not resolved.

You mean downgrade VSCode, not just the plugin... WOW....that's hard...

Yes, unfortunately. But works for now. Obviously isn't real solution, just while Atlassian or Microsoft solving the strange behavior.

Same issue here, downgrading worked for me as well.

Same issue, downgrading to 1.75.1 worked. Please can Atlassian make some progress on this.

I had same issue. Downgrade worked. Thanks!

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events