Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,041
Community Members
 
Community Events
176
Community Groups

Artifacts from the build step are not saving.

Edited

Hi All,

Just trying out bitbucket for CI/CD and having a simple, however obviously critical issue, artifacts don't seem to be saving from the build step of a pipeline.

No errors, probably something super simple I'm overlooking.

Here's the debugging version of the build step from bitbucket-pipelines.yml

 

pipelines:
branches:
master:
- step:
image: node:10.15.0
name: Build
script:
- cd app
- npm install
- npm run build
- ls
- ls ./dist
artifacts:
- dist/**

 

Attached screenshots of the build output and empty artifacts tab.

 

Anyone got any suggestions?

 

Thanks heaps.artifacts.PNGbuild.PNG

1 answer

1 accepted

0 votes
Answer accepted

lol, my bad, sorry! 

 

artifacts:
- app/dist/**

Hi I have similar problem can you help?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events