Application link from Jira to Bitbucket not working

I just upgraded Jira to 7.3.6 and in the same time moved from Stash to Bitbucket 5.0.1, both instances run on the same server. I have experienced some errors that I have not been able to resolve:

1. In the hamburger menu up to the left (the Application navigation) I can jump to Jira and Confluence (which I also updated) but the Bitbucket link directs me to the Jira starting page. 

2. To get to my Bitbucket site, I need to type the URL stash.mycompany.com. If I type bitbucket.mycompany.com I come to the Jira site just as above.

3. Possibly as a result of the error described above, I cannot create a working application link to Bitbucket. When I try to create a connection from Jira to Bitbucket, I get the error "This application has the same ID as myself. Can't create link to myself.". The connection in the list of application links is then marked with a "configuration error". Trying to create the link from Bitbucket to Jira gets the same result. Finally, I have tried to connect from Jira to localhost:7990 (Bitbucket default port) and actually the application link is then marked with "connected". However, the link to Bitbucket in the upper left application link menu still leads me to Jira, just as in #1. 

I have tried to create the application link logged in locally on the server, it also does not help (IE11 on Windows Server 2012). Any suggestions anyone?

1 answer

1 accepted

So, with some help from the skilled Atlassian support team I finally got all four applications up and running (Jira, Confluence, Bitbucket, Bamboo).

This is what I needed to do:

  1. Make sure that the Apache virtual host config files (httpd-conf and httpd-vhosts) had the value ServerName set to bitbucket.mycompany.com instead of stash.mycompany.com.
  2. Make sure that the server.xml files of Jira, Confluence and Bamboo and the bitbucket.properties file of Bitbucket did not contain any context path. If there was a context path, remove the value between the "" so it looks like (example): 
    <Context path="" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true">

Hope this can help if anyone is facing the same problems as I did.

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

636 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot