Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,383
Community Members
 
Community Events
176
Community Groups

Always seenig a mesage 'Using an account password for Git over HTTPS'

After every push I see this message in my terminal on Mac:

"

You are using an account password for Git over HTTPS.

Beginning March 1, 2022, users are required to use app passwords remote: for Git over HTTPS. To avoid any disruptions, change the password used in your Git client remote: to an app password. Note, these credentials may have been automatically stored in your Git client and/or a credential manager such as Git Credential Manager (GCM).'

A did made an app password and even installed Soursetree for that but I still see this ugly message. How to get rid of it?

2 answers

1 vote

Hi @Anastasiia Boiko and welcome to the community.

If you are still seeing this message, it is possible that the account's password is stored in Keychain Access and used instead of the app password.

I would suggest trying the following:

1. First, run the following two commands on terminal

git config --system credential.helper
git config --global credential.helper

If you see in the output of either of them osxkeychain, this means that credentials are obtained from MacOS Keychain. Please let me know if you see different output.

2. If Keychain is used, remove any credentials for bitbucket.org from Keychain Access.

3. Then make a push from the terminal. You should get asked for a password if none is stored in Keychain Access, please provide the app password.

The app password should then get stored in Keychain Access, and the message shouldn't be visible on the next push.

Regarding SourceTree:
If you have added in SourceTree your Bitbucket account from Preferences > Accounts, I would suggest removing and re-adding your Bitbucket account using an app password instead of the password.

Please feel free to let me know how it goes and if you need any further assistance.

Kind regards,
Theodora

I followed the steps and it did not work. After inserting the mentioned commands in the terminal, it did not display any keys. So I thought I did not have any keys in the Keychain Access. After pushing from the terminal, it displayed the same message in the big terminal..

Like gaidam likes this

Hi @Anita Gagarina,

The commands I shared in my reply will not show any credentials, they will show which credential manager is used by Git (if there is one configured) or no output at all in case no credential manager is configured.

Could you please create a new question in community, provide in your question the following info (as your setup may be different), and we can look into your issue

1. Are you also using MacOS or a different operating system?
2. What output do you get if you run the commands I shared in my previous reply?
3. Do you get asked for a password when you push to Bitbucket repos?
4. Do you use any Git GUI client or do you only clone/pull/push from terminal?

Kind regards,
Theodora

I have MacOS, I connect to BitBucket over HTTPS. I did not have GCM. This is how I solved the problem:

1. Install GCM:

brew tap microsoft/git
brew install --cask git-credential-manager-core

See details:  https://docs.github.com/en/get-started/getting-started-with-git/caching-your-github-credentials-in-git

2. Create BitBucket app password. 

See steps: https://bitbucket.org/blog/deprecating-atlassian-account-password-for-bitbucket-api-and-git-activity

3.  When I push first time, GCM asked my password. And I did not see the remote message anymore

Like Theodora Boudale likes this

Hi Anita,

Thank you for your reply, it's good to hear that you figured this out.

Kind regards,
Theodora

You have two options.

  • Create and use the App Password
  • Create and use an SSH Key

App Password

The App Password is needed when systems require 2-Factor authentication, to provide extra security to your accounts. Things like Git Clients, don't support these 2-Factor, so for them to connect, they need to be given a generated App Password, so that they can still connect.

It seems like you are using the official Git client in the terminal, and may have it cached within MacOS. This command should release it.

git config --unset credential.helper

 To create a App Password, follow these instructions.

SSH Key

The more secure method is to create an SSH key for authenticating to Bitbucket.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events